Facebook: User is not able to edit or add data to contacts after signing into Facebook

VERIFIED DUPLICATE of bug 819515

Status

P2
normal
VERIFIED DUPLICATE of bug 819515
6 years ago
6 years ago

People

(Reporter: cbarker, Assigned: alberto.pastor)

Tracking

unspecified
B2G C3 (12dec-1jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [interaction, UX-P1][fix in bug 819515])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 688048 [details]
Unable to edit

After logging into a Facebook Account, the user is unable to add or edit any contacts data in the Address Book.

Repro Steps: 
1. Install Build 20121203070719 on an Unagi Device
2. Go to the Contacts Menu (Have at least 1 local contact in the phone)
3. Open the Contact Settings
4. Turn on Facebook
5. Log into an existing Facebook Account
6. After logging in, return to the contacts menu (Does not matter if you import contacts or not.)
7. Select a contact and choose to edit
8. Select a field to edit or add data to

Actual Results:
The cursor will appear in the field, however the keypad will not appear making the user unable to edit or add data to contacts

Expected Results:
The user is able to edit, add, and update a contacts data as desired, even while logged into Facebook

Notes:
The fields appear grayed out when editing contacts after logging in
Repro'd 5/5 times on multiple Unagi devices
See attached screenshot for more info
(Reporter)

Updated

6 years ago
Summary: [B2G][Contacts] Facebook Imports: User is not able to add data to contacts imported from Facebook → [B2G][Contacts] Facebook: User is not able to edit or add data to contacts after signing into Facebook

Comment 1

6 years ago
positioning this as UX-P1 because the user has no way of knowing why they are unable to edit the data associated to contacts and therefore no why of being able to recover from this error.
Whiteboard: interaction [UX-P1]
Good find. This is a major functional bug. Nominating for reasons cited.
blocking-basecamp: --- → ?
Summary: [B2G][Contacts] Facebook: User is not able to edit or add data to contacts after signing into Facebook → Facebook: User is not able to edit or add data to contacts after signing into Facebook
Whiteboard: interaction [UX-P1] → interaction, UX-P1
Assignee: nobody → jmcf
blocking-basecamp: ? → +
Priority: -- → P2
(Assignee)

Updated

6 years ago
Assignee: jmcf → alberto.pastor
(Assignee)

Updated

6 years ago
Depends on: 819515

Updated

6 years ago
Target Milestone: --- → B2G C3 (12dec-1jan)
No update for a week - Alberto, do you have an ETA for when this will be fixed?
I think this should be fixed by bug 819515.
(Assignee)

Comment 5

6 years ago
Yep, Tim is right, should be fixed with that bug. Just keeping this one for verifying after 819515 is solved
Whiteboard: interaction, UX-P1 → [interaction, UX-P1][fix in bug 819515]
Definitively an occurence of the window.open bug that is seen in UI tests as well. Alberto feel free to reopen the bug if it still happens once bug 819515 has landed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 819515

Updated

6 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM

Comment 7

6 years ago
Unagi build 20130211070202, Dec 5th Kernel

Verified as a duplicate of bug 819515
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.