[Contacts] Even if Facebook is disabled, you can still click facebook switch

VERIFIED FIXED in B2G C3 (12dec-1jan)

Status

Firefox OS
Gaia::Contacts
P3
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: alberto.pastor, Assigned: basiclines)

Tracking

unspecified
B2G C3 (12dec-1jan)
x86
Mac OS X

Firefox Tracking Flags

(blocking-basecamp:-, b2g18+ fixed)

Details

Attachments

(1 attachment)

PR
252 bytes, text/html
Jose Manuel Cantera
: review+
Details
(Reporter)

Description

6 years ago
STR:

1.- Open contacts app (without internet connection)
2.- Click Settings button
3.- Click the disabled facebook switch

Expected:

Nothing happens

Actual:

The switch receives the click and change its status.
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?

Comment 1

6 years ago
well spotted Alberto.

Comment 2

6 years ago
I have been investigating a bit and it seems the switch BB does not support a disabled mode, thus the transition is triggered always. Assigning to Ismael and Arnau in order to extend the BB to support a disabled state
Assignee: nobody → igonzaleznicolas
Status: NEW → ASSIGNED
blocking-basecamp: ? → +
Priority: -- → P3

Comment 3

6 years ago
Mass Modify: All un-milestoned, unresolved blocking-basecamp+ bugs are being moved into the C3 milestone. Note that the target milestone does not mean that these bugs can't be resolved prior to 12/10, rather C2 bugs should be prioritized ahead of C3 bugs.
Target Milestone: --- → B2G C3 (12dec-1jan)

Updated

6 years ago
Duplicate of this bug: 820384

Comment 5

6 years ago
We won't block on this, but we would take a low risk uplift. Unblocking, but tracking for the branch.
blocking-basecamp: + → -
tracking-b2g18: --- → +
(Assignee)

Comment 6

6 years ago
Created attachment 699678 [details]
PR

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #699678 - Flags: review?(jmcf)
Attachment #699678 - Flags: approval-gaia-master?(francisco.jordano)

Updated

6 years ago
Attachment #699678 - Flags: review?(jmcf) → review+
Comment on attachment 699678 [details]
PR

To me a bb+

We already have the patch, is reviewed, and working for me.

a=me

Thanks guys!
Attachment #699678 - Flags: approval-gaia-master?(francisco.jordano) → approval-gaia-master+

Comment 8

6 years ago
https://github.com/mozilla-b2g/gaia/commit/7d6e82223cb60d27232cd2b6b19c99b8c0db3580
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 9

6 years ago
2012/28/01 build. Gecko-cfad7c9 Gaia-6c53dfd
Status: RESOLVED → VERIFIED
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.