scrolling invalidation on https://developer.mozilla.org/en-US/apps

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: mayankleoboy1, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 688118 [details]
about support.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121202 Firefox/20.0
Build ID: 20121202030723

Steps to reproduce:

1. Enable debug paint flash
2. Go to : https://developer.mozilla.org/en-US/apps
3.  Put the vertical scroll bar approximately in the middle
4. Move scroll bar   up and down a bit. 


Actual results:

 Invalidation of the page. 


Expected results:

No invalidation.
(Reporter)

Comment 1

6 years ago
Comment #1 was with HWA on. As you scroll down a bit from the middle position, there is a visible horizontal size change of the text area, which probably causes the repaint.



With HWA OFF, the complete page invalidates continuously on scrolling , using 90% CPU.

Updated

6 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core
(Reporter)

Updated

6 years ago
Component: Plug-ins → Layout

Comment 2

6 years ago
Can you reproduce this issue with a clean profile or in safe mode?
http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(mayankleoboy1)
(Reporter)

Comment 3

6 years ago
can repro with a new profile.

comment #0 and comment #1 might be two different bugs
Flags: needinfo?(mayankleoboy1)

Comment 4

6 years ago
There is no change in CPU usage on my machine, but I do see some repaints every now and then while reproducing the steps in comment 0.

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:21.0) Gecko/20130109 Firefox/21.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

6 years ago
comment 0 was with HWA on.

If you repeat the STR of comment 0 with HWA off, you will see full page invalidation.

Comment 6

6 years ago
(In reply to Ioana Budnar [QA] from comment #4)
> There is no change in CPU usage on my machine, but I do see some repaints
> every now and then while reproducing the steps in comment 0.
> 
> Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:21.0) Gecko/20130109 Firefox/21.0

I should have mentioned that was with HWA off.

With HWA on, I do see some changes in CPU usages but they are rather normal (increases and decreases by at most 5% every now and then).
(Reporter)

Comment 7

6 years ago
for me, with HWA on , there is some invalidation on the page while scrolling.

With HWA off, there is continuous full page invalidation. CPU usage could depend on many factors, including speed of scrolling and maybe screen size too.


similar effect can be observed here :  https://developer.mozilla.org/en-US/
Scroll down slowly. You will see some fantastic invalidation.

In fact, similar invalidation behaviour is present on a lot of mozilla pages. So maybe investigate this ?
(Reporter)

Comment 8

4 years ago
page has changed.
cant reproduce anymore
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.