Order of variables for date elements is wrong for locales in Homescreen

RESOLVED FIXED

Status

Firefox OS
Gaia::Homescreen
P3
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: pascalc, Assigned: stas)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:-)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 688227 [details]
screenshot of the bug

On the Home Screen, the date is badly displayed in French, the words are translated but the format uses English syntax.

The lockscreen does not have this bug.

Lockscreen: mardi 4 décembre
Homescreen: mardi, décembre 4

I see that with a Firefox OS Desktop client based on the mozilla-beta repo + the gaia repo

I have a small patch that fixes that locally. Will do a pull request referencing this bug
(Reporter)

Comment 1

5 years ago
Created attachment 689185 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6804

Pointer to Github pull-request
(Reporter)

Updated

5 years ago
Attachment #689185 - Flags: review?(kaze)
Comment on attachment 689185 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6804

Unless I miss something, the fix you propose would not work in English.

The real fix would be to understand why the _('longDateFormat') string is not properly returned. This looks like an initialization issue (e.g. init before l10n is ready).
Attachment #689185 - Flags: review?(kaze) → review-
However, this bug remains valid and should be fixed ASAP. Nominating for blocking-basecamp.
blocking-basecamp: --- → ?
Blocks bug 811242 which is bb+.
Blocks: 811242
Assignee: nobody → kaze
Target Milestone: --- → B2G C2 (20nov-10dec)
blocking-basecamp: ? → +
Priority: -- → P3
OK, turns out the problem is a pure l10n one: the code works fine but the homescreen/locales/*.properties files are not up-to-date. As _('longDateFormat') is not defined for French (nor for any other supported locale in this repository…), the English format is used instead.

Pike and/or Staś, would you please update the Gaia repository with the *.properties files for [ar], [fr] and [zh-TW] from your repo?
Assignee: kaze → l10n
Target Milestone: B2G C2 (20nov-10dec) → ---

Comment 6

5 years ago
stas said that he's doing another migration before going on PTO
Assignee: l10n → stas
(Assignee)

Comment 7

5 years ago
I opened https://github.com/mozilla-b2g/gaia/pull/6863.  I'll probably open a new bug, too.
(Assignee)

Updated

5 years ago
Depends on: 818999

Comment 8

5 years ago
From our read, this doesn't impact any 1.0 shipping locales. We can revisit for a future version.
blocking-basecamp: + → -
fixed by bug 818999
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.