device builds with gaia multilocale enabled fail

RESOLVED DUPLICATE of bug 817170

Status

Firefox OS
Gaia
P1
normal
RESOLVED DUPLICATE of bug 817170
5 years ago
5 years ago

People

(Reporter: bhearsum, Assigned: stas)

Tracking

unspecified
B2G C2 (20nov-10dec)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

5 years ago
This happened the first time we tried to land this, and then again today. Forgot to file a bug for it the first time :(.

06:25:11     INFO -  cp /builds/slave/b2g-m-aurora-panda-dep/build/gaia/profile/user.js out/target/product/panda/system/b2g/user.js
06:25:11     INFO -  cp: cannot stat `/builds/slave/b2g-m-aurora-panda-dep/build/gaia/profile/user.js': No such file or directory
(Reporter)

Comment 1

5 years ago
09:48 < stas> bhearsum: does the same thing happen when you unset LOCALE_BASEDIR ?
(Reporter)

Comment 2

5 years ago
Blocks multilocale gaia builds, marking as C2, noming for blocking-basecamp.
blocking-basecamp: --- → ?
Target Milestone: --- → B2G C2 (20nov-10dec)
(Reporter)

Comment 3

5 years ago
(In reply to Ben Hearsum [:bhearsum] from comment #1)
> 09:48 < stas> bhearsum: does the same thing happen when you unset
> LOCALE_BASEDIR ?

This only happens with LOCALE_BASEDIR set.
(Reporter)

Updated

5 years ago
Blocks: 812831
blocking-basecamp: ? → +
Priority: -- → P1
(Reporter)

Updated

5 years ago
Depends on: 818142
(Reporter)

Updated

5 years ago
Depends on: 818143
(Reporter)

Comment 4

5 years ago
Stas is going to be looking into this, assigning to him for now. I'll be helping in way I can.
Assignee: nobody → stas
(Reporter)

Comment 5

5 years ago
While I was setting up a slave for Stas I noticed that a rebuild inside of the same objdir seems to work fine. So it seems like one of two things is happening here;
- Dep builds create gaia/profile/user.js but clobbers don't
- Dep builds don't look for this file at all, but clobbers do
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 817170
You need to log in before you can comment on or make changes to this bug.