PDF viewer displays e-tickets purchased through ns.nl incorrectly (strange colors)

RESOLVED DUPLICATE of bug 848641

Status

()

Firefox
PDF Viewer
P3
normal
RESOLVED DUPLICATE of bug 848641
6 years ago
5 years ago

People

(Reporter: ehoogeveen, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-jpeg], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 688271 [details]
Example ticket (generated by ns.nl)

The PDF viewer in Firefox doesn't render the PDFs generated by the e-ticket service on www.ns.nl correctly. They should be black and white aside from the NS logo and a red square to the left of the SecuTix text at the bottom, but instead several patches are displayed with an awful green or purple background color. This effect remains when printing the ticket from Firefox, potentially invalidating the QR code (though I haven't gone out of my way to verify if it still works). Adobe Reader 11.0 displays the tickets correctly.

I confirmed that the issue is not related to color management by setting gfx.color_management.mode to false, and tested on the latest beta of Firefox 18 and the current Nightly (2012-12-04) - both show the same result.

This bug might be similar in nature to bug 798748 (error console shows the same message as quoted in bug 798748 comment #1, among others), but Firefox's rendering is much more clearly wrong in this case.

STR:
Open the attached file in Firefox

Expected result:
All but the NS logo and a rectangle next to the 'SecuTix' text is black and white.

Actual result:
Several large patches, including the QR code have an obviously wrong background color (green or purple).

Updated

6 years ago
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-jpeg]
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20130102 Firefox/20.0

Confirming the issue on latest Nighlty - build id 20130102030907.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

5 years ago
Looks like bug 848641 fixed this as I no longer see it (that is, the pdf displays correctly) on today's Nightly! Not sure whether to mark this as RESOLVED WORKSFORME or wait for someone to mark it as RESOLVED FIXED - I'll leave it for now.
Depends on: 848641
The usual rule is:

If we know which bug fixed it, we DUP to it (RESOLVED/DUP)
If the fix is inside the bug: RESOLVED/FIXED
If an unknown other fix (in an unknown bug) fixed it: RESOLVED/WORKSFORME

So I'm dupping it. (even if bug 848641 is a "multifix" bug)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 848641
You need to log in before you can comment on or make changes to this bug.