Gaia’s “Legal Information” needs ironing

RESOLVED FIXED in B2G C3 (12dec-1jan)

Status

P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: kaze, Assigned: kaze)

Tracking

({late-l10n})

unspecified
B2G C3 (12dec-1jan)
x86_64
Linux
late-l10n

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(3 attachments)

(Assignee)

Description

6 years ago
I’ve been urged to land bug 811677 quickly but I think it needs some further ironing.

 • Device Information > Legal Information leads to an almost empty page holding:
    - a "Legal Information" title (which is fine)
    - a "Mozilla" subheading (which I’m not sure makes any point)
    - a truncated and mis-aligned "B2G OS Open Source Notices" item

 • clicking on this item, we get to another page with:
    - a truncated "B2G OS Open Source Notices" title (which is bad)
    - a full-page <iframe> with the license notes, in English

Larissa, would you please review this? I’m not sure we need the intermediate page but I’ll trust your opinion on that.

On the technical side, there are two details that could be fixed:
 • the indentation should be done with *spaces* please, not tabs;
 • the license file name should follow our common guidelines, i.e. no dashes; and it could be stored in resources/open_source_license.html rather than at the root directory.
(Assignee)

Updated

6 years ago
Assignee: nobody → mbudzynski
blocking-basecamp: --- → ?
Flags: needinfo?(lco)
(Assignee)

Comment 1

6 years ago
Created attachment 688313 [details]
screenshot — "Legal Information"
(Assignee)

Comment 2

6 years ago
Created attachment 688314 [details]
screenshot — "B2G OS Open Source Notices"

Comment 3

6 years ago
(In reply to Fabien Cazenave [:kaze] from comment #0)
> I’ve been urged to land bug 811677 quickly but I think it needs some further
> ironing.
> 
>  • Device Information > Legal Information leads to an almost empty page
> holding:
>     - a "Legal Information" title (which is fine)
>     - a "Mozilla" subheading (which I’m not sure makes any point)

I'll explain why we have this in the point below. Actually, we also need a subheading that says "Other" right below the link in the subheading.
 
>     - a truncated and mis-aligned "B2G OS Open Source Notices" item

Why is the text indented so much in this link? There won't be any icon, so feel free to remove the indent. Even removing the indent, I don't know if the text will fit. If it doesn't fit, we might have to shorten it to "Open Source Notices" only. Ping'ing Gerv to see if he's ok with this.

 
>  • clicking on this item, we get to another page with:
>     - a truncated "B2G OS Open Source Notices" title (which is bad)

Let's see if Gerv is ok with just "Open Source Notices". Also, I don't know why your title says "B2G" instead of "Firefox OS" anyway. On my build, it says "Firefox OS". We shouldn't be surfacing "B2G" anywhere in the device because it's not an external name.

>     - a full-page <iframe> with the license notes, in English
> 
> Larissa, would you please review this? I’m not sure we need the intermediate
> page but I’ll trust your opinion on that.

I brought this up as well, but Gerv says that there will be other links on that intermediate page in v1 (potentially from other partners), which is why we have this intermediate page.

> 
> On the technical side, there are two details that could be fixed:
>  • the indentation should be done with *spaces* please, not tabs;
>  • the license file name should follow our common guidelines, i.e. no
> dashes; and it could be stored in resources/open_source_license.html rather
> than at the root directory.
Flags: needinfo?(lco) → needinfo?(gerv)
(Assignee)

Comment 4

6 years ago
(In reply to Larissa Co from comment #3) 
> Why is the text indented so much in this link? There won't be any icon, so
> feel free to remove the indent. Even removing the indent, I don't know if
> the text will fit. If it doesn't fit, we might have to shorten it to "Open
> Source Notices" only. Ping'ing Gerv to see if he's ok with this.
> 

The indent is caused by the unwanted |class="description"| attribute on the list item, but even without this indent and with the shorter “B2G” string (instead of “Firefox OS”) it doesn’t fit.
So, +1 for using “Open Source Notices” instead if Gerv is OK with that (or just “Open Source”?).

> Let's see if Gerv is ok with just "Open Source Notices". Also, I don't know
> why your title says "B2G" instead of "Firefox OS" anyway. On my build, it
> says "Firefox OS". We shouldn't be surfacing "B2G" anywhere in the device
> because it's not an external name.
> 

The B2G vs. Firefox OS thing is just a matter of branding and depends on the type of build — don’t worry about that.
(Assignee)

Comment 5

6 years ago
Created attachment 688715 [details]
patch proposal
Assignee: mbudzynski → kaze
Status: NEW → ASSIGNED
Attachment #688715 - Flags: review?(ehung)
Attachment #688715 - Flags: feedback?(gerv)
(Assignee)

Updated

6 years ago
Keywords: late-l10n
I'm OK with "Open Source Notices" if "Firefox OS Open Source Notices" is too long.

Gerv
Flags: needinfo?(gerv)
blocking-basecamp: ? → +
Priority: -- → P1

Comment 7

6 years ago
Mass Modify: All un-milestoned, unresolved blocking-basecamp+ bugs are being moved into the C3 milestone. Note that the target milestone does not mean that these bugs can't be resolved prior to 12/10, rather C2 bugs should be prioritized ahead of C3 bugs.
Target Milestone: --- → B2G C3 (12dec-1jan)
(Assignee)

Updated

6 years ago
Attachment #688715 - Flags: feedback?(gerv)

Comment 8

6 years ago
Comment on attachment 688715 [details]
patch proposal

r=me, thanks!
Attachment #688715 - Flags: review?(ehung) → review+

Comment 9

6 years ago
https://github.com/mozilla-b2g/gaia/pull/6823
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 10

6 years ago
Oh, I forgot the late-l10n process, we should also add Staś to review this patch so he can notice those late strings.
reopen and add Staś to patch reviewer.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

6 years ago
Attachment #688715 - Flags: review?(stas)
(Assignee)

Comment 11

6 years ago
Staś, I’m afraid this patch has been merged already:
https://github.com/mozilla-b2g/gaia/commit/7baaf75636e48af19f91022bddb388167fc5c3d2

Please let us know if that’s OK.

Comment 12

6 years ago
Sorry about merging it first. :'(
Comment on attachment 688715 [details]
patch proposal

r=me, post-factum.  Thanks :)
Attachment #688715 - Flags: review?(stas) → review+
(Assignee)

Updated

6 years ago
Blocks: 812955
(Assignee)

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.