Closed Bug 818220 Opened 8 years ago Closed 8 years ago

sometimes the audio restarts when an app is in background

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla20
Tracking Status
firefox18 --- verified
firefox19 --- verified
firefox20 --- verified

People

(Reporter: baku, Assigned: baku)

References

Details

Attachments

(1 file)

No description provided.
Attached patch patch aSplinter Review
Attachment #688406 - Flags: review?(kinetik)
Attachment #688406 - Flags: review?(kinetik) → review+
Comment on attachment 688406 [details] [diff] [review]
patch a

Review of attachment 688406 [details] [diff] [review]:
-----------------------------------------------------------------

This is safe for all non-b2g branches.
Attachment #688406 - Flags: approval-mozilla-beta+
https://hg.mozilla.org/mozilla-central/rev/8f92b512bf11
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Can somebody who could reproduce this issue add some STR please?
QA Contact: mariomihai22
Andrea can you please answer to Comment 7 ?
(In reply to MarioMi from comment #7)
> Can somebody who could reproduce this issue add some STR please?

Sorry for the delay. This bug was reproducible when the music app was not using content channel.
At that time the steps were:

1. open the music app and play the first song
2. press home (the music app goes in background and it's muted - now it's not because of the content channel)
3. wait until the first song (muted) ends.
4. the second song starts unmuted.

The same steps can be recreated with an html page.
QA Contact: mariomihai22
Verified Fixed on FF 18 and FF 19b2 on Ubuntu x86 following STR from Comment 9.

Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0(20130104154505)

Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/20100101 Firefox/19.0(20130116072953)
I confirm the fix is verified on FF 20.b1 too on Ubuntu 12.04 x86:

Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0(20130220104816)
Status: RESOLVED → VERIFIED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.