Device did not reboot, it did change language after the intro walk through was complete.

RESOLVED INVALID

Status

Firefox OS
Gaia::First Time Experience
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: ehamel@qanalydocs.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Build ID: 2012 1204070731  V 1.0.0
Test Case #2329

Steps to Reproduce: 
During first time user:
1. Open phone > Select new language > Click Next button

Actual result: 
Device did not reboot, it did change language after the intro walk through was complete.

Expected result: 
Verify system reboots
I'm not sure I do understand completely this bug. 

Do you mean that you expected the phone to reboot when you change language?

Did the phone changed language when you pressed next? Or did it changed when you finished the FirstTime?

Please clarify the details,
Thanks for reporting anyway! :)
Flags: needinfo?(ehamel)
(Reporter)

Comment 2

5 years ago
The expected result for this test is:

Expected result: 
Verify system "reboots"

Taking the test literally I was expecting it to reboot however, it did change language after the intro walk through was complete.

This may just be a problem with how the test script is written.
Flags: needinfo?(ehamel)

Updated

5 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Long time sitting bug, I think it's already fixed (uncertain of when exactly, I tried latest builds).

When I change language, I expect the language to be changed immediately, and keep using the FTE on the new language.

Please QA confirms if that's the expected case.
Keywords: qawanted

Comment 4

4 years ago
Since the phone is not supposed to reboot with a language change. ("Currently") -Removing the QAwanted tag.

Also here is a bug that is very similar and might be causing slight confusion with the "Need" to reboot.

https://bugzilla.mozilla.org/show_bug.cgi?id=968398
Keywords: qawanted

Updated

4 years ago
QA Contact: pfield
Closing this as invalid, bug 968398 adequately covers any expectations of reboot, we dont expect to need this in FTU.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.