Status

Release Engineering
General Automation
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: armenzg, Assigned: armenzg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
There is a networking change that allows the b2g pandas to come back up with networking working.

Could you please help me update the snapshot? Thanks in advance.

The change was landed in here:
https://github.com/mozilla-b2g/android-device-panda/commit/63196b48f479c30787863c8ca89456acd4b03910
I'll take care of this today.
Assignee: nobody → nthomas
Priority: -- → P2
The build was green on try, so you're clear to go ahead with review and landing this wherever is sensible.
Assignee: nthomas → armenzg

Updated

5 years ago
Attachment #688539 - Flags: review+

Comment 5

5 years ago
Comment on attachment 688539 [details] [diff] [review]
[m-c or equiv] update snapshot

[Approval Request Comment]
Bug caused by (feature/regressing bug #):

We need the fix from bug 810045 in the Panda image to [partially] unblock Gaia smoketests.

User impact if declined: 

No networked Panda images.

Testing completed (on m-c, etc.): 

Tested on Try.  We can wait til m-c goes green first if desired.

Risk to taking this patch (and alternatives if risky):

The current Panda image isn't currently usable in automation, so I suppose the biggest risk is potential build bustage, but we were green on Try.

String or UUID changes made by this patch: 

N/A
Attachment #688539 - Flags: approval-mozilla-beta?
Attachment #688539 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Blocks: 815785

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/d44b6f0b2cf7
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 7

5 years ago
(In reply to Aki Sasaki [:aki] from comment #5)
> Risk to taking this patch (and alternatives if risky):
> 
> The current Panda image isn't currently usable in automation, so I suppose
> the biggest risk is potential build bustage, but we were green on Try.

Thanks for the caution here.

Updated

5 years ago
Attachment #688539 - Flags: approval-mozilla-beta?
Attachment #688539 - Flags: approval-mozilla-beta+
Attachment #688539 - Flags: approval-mozilla-aurora?
Attachment #688539 - Flags: approval-mozilla-aurora+
This is breaking builds on aurora and beta, looks like a missing header

11:44:55 ERROR - ../../../../../../../../gecko/toolkit/crashreporter/google-breakpad/src/common/android/include/link.h:47: error: 'ElfELFSIZE_Addr' does not name a type
11:44:55 ERROR - ../../../../../../../../gecko/toolkit/crashreporter/google-breakpad/src/common/android/include/link.h:52: error: 'ElfELFSIZE_Addr' does not name a type
11:44:55 ERROR - ../../../../../../../../gecko/toolkit/crashreporter/google-breakpad/src/common/android/include/link.h:56: error: 'ElfELFSIZE_Addr' does not name a type
11:44:55 ERROR - ../../../../../../../../gecko/toolkit/crashreporter/google-breakpad/src/common/android/include/link.h:58: error: ISO C++ forbids declaration of 'ElfELFSIZE_Dyn' with no type
11:44:55 ERROR - ../../../../../../../../gecko/toolkit/crashreporter/google-breakpad/src/common/android/include/link.h:58: error: expected ';' before '*' token
11:44:55 ERROR - make[8]: *** [minidump_writer.o] Error 1
11:44:55 ERROR - make[7]: *** [libs] Error 2
11:44:55 ERROR - make[6]: *** [crashreporter_libs] Error 2
11:44:55 ERROR - make[5]: *** [libs_tier_platform] Error 2
11:44:55 ERROR - make[4]: *** [tier_platform] Error 2
11:44:55 ERROR - make[3]: *** [default] Error 2
11:44:55 ERROR - make[2]: *** [realbuild] Error 2
11:44:55 ERROR - make[1]: *** [build] Error 2
11:44:55 ERROR - Return code: 2
11:44:57 FATAL - failed to build
11:44:57 FATAL - Exiting 2

Comment 10

5 years ago
Ok, unless someone knows what needs to be synced over I'll back out in m-a and m-b.

Comment 11

5 years ago
Comment on attachment 688539 [details] [diff] [review]
[m-c or equiv] update snapshot

Backed out of m-a and m-b due to bustage.

http://hg.mozilla.org/releases/mozilla-aurora/rev/86af495d562c
http://hg.mozilla.org/releases/mozilla-beta/rev/bc6356e7ebd0

We still need these on those branches, but we need to figure out what's missing first.
That's because this change isn't present on aurora or beta:
  http://hg.mozilla.org/mozilla-central/rev/cb06eaa3d700
Depends on: 809367

Comment 13

5 years ago
bug 819979 will uplift to aurora+beta, which will resolve the rest of this bug.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.