xpidl_idl.c error handling for #include "foo

RESOLVED FIXED in M8

Status

()

Core
XPCOM
P3
minor
RESOLVED FIXED
19 years ago
10 years ago

People

(Reporter: Mike McCabe, Assigned: Michael Ang)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using #include "foo (without the trailing quote) in an .idl file produces an
error message (via fprintf, should report a line number instead) but goes on to
fail an assert and crash.

Shaver - I know fixing xpidl_idl.c was officially a favor, but I'm guessing
you're still close 'n' affectionate with the new code.  Please pass it off to me
or mang if you prefer.

Updated

19 years ago
Status: NEW → ASSIGNED
I agree about wanting a line number there, and I think I can get one from
IDL_file_set.  Not sure how I can report the error better, though, since I need
an IDL_tree to call the usual libIDL reporting functions, and we're not that far
into the parse yet.

I'll look and stuff.
(Assignee)

Updated

19 years ago
Assignee: shaver → mang
Status: ASSIGNED → NEW
(Assignee)

Comment 2

19 years ago
I have fixes to report the errors using the name and line of the original file.
I'll get these reviewed with my other line number fixes and check in when the
tree opens for m8.

I couldn't reproduce the crash.  Should we just exit when we see that we can't
include a file?  Right now we get a hokey error message from libIDL:
"input callback returned failure"
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

19 years ago
When you assign yourself a bug it should be automagically accepted.  Waah.
What does exit() do when you're running as a CodeWarrior plug-in on the Mac?  I
don't know, and I'm not sure I want to find out.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Target Milestone: M8
(Assignee)

Comment 5

19 years ago
Fix checked in.

Updated

10 years ago
Component: xpidl → XPCOM
QA Contact: mike+mozilla → xpcom
You need to log in before you can comment on or make changes to this bug.