zh-tw builds have {{brandshortName}} in the UI

RESOLVED FIXED

Status

Firefox OS
GonkIntegration
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 688524 [details]
screenshot

Tested on the multilocale builds that bhearsum generated.  some screens are still showing the placeholders for {{brandShortName}} 

See screenshot

Repro:
1) install multilocale build, otoro
2) select chinese
3) go to settings, and verify l10n placeholder

Expected:
- localized
Given that this is zh-TW only, maybe it's a locale issue?
The string https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/locales/settings.en-US.properties#L404 doesn't exist in zh-TW, so it seems that parameter substitution doesn't happen when picking up fallback strings at runtime? Kaze?
Right. This should be fixed by either creating the proper branding.zh-TW.properties file ,or by removing the [zh-TW] (and [fr]…) sections from the branding.ini file here: https://github.com/mozilla-b2g/gaia/blob/master/shared/locales/branding.ini

That being said, l10n.js should be able to ignore non-existing files, see bug 816978.
It looks like this string was added on 12-12-12.

https://github.com/mozilla-b2g/gaia/blame/master/shared/locales/branding/unofficial/branding.zh-TW.properties
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.