[FTU] [Settings] Share info filled during FTU (i.e. "Improve Firefox OS" checkbox)

RESOLVED FIXED in B2G C3 (12dec-1jan)

Status

P3
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dholbert, Assigned: fcampo)

Tracking

({b2g-testdriver, unagi})

unspecified
B2G C3 (12dec-1jan)
ARM
Gonk (Firefox OS)
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
I just re-flashed with the unagi_beta_2012-12-03.zip dogfood build, and during the first run experience, I ticked the checkbox for "Submit performance data" etc. in the second-to-last screen.

Then, after completing that process, I went over to settings and checked the "Improve Firefox OS" section. I expect that the "Submit Performance Data" checkbox should be checked, but it's not.
Component: Gaia → Gaia::Settings
(Reporter)

Comment 1

6 years ago
Created attachment 688560 [details]
screenshot of box that I checked during first-run experience

Here's a screenshot of the first-run experience page where I ticked the box.
(Reporter)

Comment 2

6 years ago
Created attachment 688562 [details]
screenshot of "Improve Firefox OS" settings page w/ box un-ticked

...and here's a screenshot of the "Improve Firefox OS" page w/ "submit performance data" un-ticked (as it appeared when I first visited it, after completing first run experience)
(Reporter)

Updated

6 years ago
Attachment #688562 - Attachment description: screenshot of "Improve Firefox OS" settings page → screenshot of "Improve Firefox OS" settings page w/ box un-ticked
Borja renominate if needed
blocking-basecamp: ? → -
Flags: needinfo?(oteo)
Flags: needinfo?(fbsc)
I've renamed the bug because the problem is that currently we have no mechanism to share the info filled during FTU to 'Settings' app. Probably we could use mozSettings, but I would like to know the opinion of Kaze.
Flags: needinfo?(fbsc) → needinfo?(kaze)
Summary: Settings "Improve Firefox OS" has all boxes unchecked, even though I ticked the box in First Run Experience → [FTU] [Settings] Share info filled during FTU (i.e. "Improve Firefox OS" checkbox)
Yup, a mozSetting would make sense.
Flags: needinfo?(kaze)
Vivien would not be so happy adding a lot of stuff in mozSetting, I would like to be sure that we agree on it.
Flags: needinfo?(21)
(In reply to dscravaglieri from comment #3)
> Borja renominate if needed

After testing it in my device, it should be BB+ as we need to have updated the info modified in FTU in the settings app.
Flags: needinfo?(oteo)
(In reply to Borja Salguero [:borjasalguero] (limited access to email until 10th December) from comment #6)
> Vivien would not be so happy adding a lot of stuff in mozSetting, I would
> like to be sure that we agree on it.

I thought this one was already a mozSettings. I am 100% fine with this one beeing a mozSetting. (The one I'm worried about beeing the email of the last section).
Flags: needinfo?(21)
blocking-basecamp: - → ?
Gaia Triage : + , seems like broken functionality.
blocking-basecamp: ? → +
Priority: -- → P3
Assignee: nobody → kaze
Target Milestone: --- → B2G C3 (12dec-1jan)
Been over a week - what needs to happen here to fix this?
(Assignee)

Comment 11

6 years ago
Stealing :) as my other blockers are on discussion and I have some time right now
Assignee: kaze → fernando.campo
Attachment #692625 - Flags: review?(fbsc) → review+
(Assignee)

Comment 13

6 years ago
https://github.com/mozilla-b2g/gaia/commit/e38fe1e99841b0515b218851211234141bfc4f35
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.