[contacts] contact list hangs on 'loading contacts'

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: maat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: interaction, UX-P?)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
**path**

a.1) select contacts icon in icon tray on home screen

OR

b.1) select dialer icon in icon tray on home screen
b.2) select contacts icon in icon set (call log, contacts, dialer) at the bottom of the screen

**expected**

if phone has contacts on it
   - contacts list loads

if phone does not have contacts on it
   - screen inviting user to import or add contacts presented

**actual**
system stuck on the 'Loading contacts...' transition overlay with spinner spinning round, and round, and round, and round, and round, and round, and ....ohh I feel queazy...
(Reporter)

Comment 1

6 years ago
Created attachment 688676 [details]
contact list hanging on 'loading contacts'

image uploaded to confirm screen process is stuck on
(Reporter)

Updated

6 years ago
Whiteboard: Interaction, UX-P1

Comment 2

6 years ago
please provide more details on what was happening also logcat traces would help
Status: NEW → UNCONFIRMED
Ever confirmed: false
QA, can you verify?
Keywords: qawanted
(Reporter)

Comment 4

6 years ago
Hi Jose

Sorry...

1) i reset the phone after filing this bug 
2) ...therefore i cannot send you logcat traces
3) ...and now the contact list is working fine again.
4) i dont *know* now to reproduce the bug as it 'just occurred' in routine usage 
5) I have tried to force the bug to reproduce, but have so far failed 

QA request removed as this is not ready to go to QA
Keywords: qawanted
Hmm.. okay, am bumping this to UX-P? until resolved. Means we're tracking it, but have not assigned priority until we confirm it's a real issue.
Whiteboard: Interaction, UX-P1 → interaction, UX-P?
Am not seeing this in current builds, but long load time of large contact sets is extremely problematic, and should be resolved. Will file separate bug for that.
Can we get QA to verify this is no longer an issue and then close?
Keywords: qawanted

Comment 8

6 years ago
Cannnot reproduce it in BUILD ID: 20130108070203
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.