Closed Bug 818451 Opened 12 years ago Closed 12 years ago

[toolbox] Opening a tool from menu should re-focus Toolbox window

Categories

(DevTools :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 815239

People

(Reporter: miker, Unassigned)

References

Details

Attachments

(1 file)

Right now if you have a toolbox open in a separate window and you select a tool using a keyboard shortcut or the menuitem, the toolbox will switch to the tool but the browser window will remain focused.

We should focus the toolbox window after switching to the tool.

This is not a duplicate of bug 818442, which only applies when a node is locked with the highlighter.

Original Github issue:
https://github.com/joewalker/devtools-window/issues/100
Depends on: 817385
No longer depends on: 817385
Depends on: 815239
Attached patch patch v1Splinter Review
Attachment #691259 - Flags: review?(jwalker)
This will be solved in bug 815239.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Comment on attachment 691259 [details] [diff] [review]
patch v1

Review of attachment 691259 [details] [diff] [review]:
-----------------------------------------------------------------

Cancelling review for review done in bug 815239.
Attachment #691259 - Flags: review?(jwalker)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: