If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Panning vertically is very jittery

RESOLVED FIXED in Firefox 21

Status

Firefox OS
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: st3fan, Assigned: kentuckyfriedtakahe)

Tracking

({b2g-testdriver, unagi})

unspecified
B2G C4 (2jan on)
x86
Mac OS X
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:-, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18+ fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
When panning vertically slowly, for example while reading an article, the text seems to rapidly jump up and down.

It does not jump up and down a lot. Probably just 1 or 2 pixels. But the effect is bad enough to make me a little seasick :-/

I'm not sure if this is a rendering or gesture issue. It does seem to depend on the zoom level.
Where do async pan and zoom bugs live? I think this is a dupe.
Component: Gaia::Browser → General
Whiteboard: DUPEME
Related bug 812517? However, already fixed in the beta build on which Stefan experienced this issue.

Comment 3

5 years ago
per comment #2
Status: NEW → RESOLVED
blocking-basecamp: ? → -
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
I can reproduce this reliably in the browser on a 2012-12-21 07:02:01 build (nightly).  I was browsing this site:  http://wp.me/p1jETZ-dH on my unagi.  Dragging my finger slowly upwards to scroll the page gives the rapid up-and-down motion of the text.
Status: RESOLVED → REOPENED
blocking-basecamp: - → ?
Resolution: WORKSFORME → ---
Assignee: nobody → roc
blocking-basecamp: ? → +
Target Milestone: --- → B2G C3 (12dec-1jan)
(In reply to Lawrence Mandel [:lmandel] from comment #2)
> Related bug 812517? However, already fixed in the beta build on which Stefan
> experienced this issue.

This isn't the "dancing text" symptom; the text snapping stays consistent.  Rather, this looks like an offset computation in APZC going wrong.
Assignee: roc → ajones
Is bug 824702 a dupe of this?

(And FWIW I can still reproduce this on a 2012-12-30 build on Unagi)
(In reply to Andrew Overholt [:overholt] from comment #6)
> Is bug 824702 a dupe of this?

While the symptoms are the same, they're not exactly the same so I don't think they're dupes.

Updated

5 years ago
Target Milestone: B2G C3 (12dec-1jan) → B2G C4 (2jan on)
We discussed this again at triage today and while we'd *love* to see a patch for this, we decided we can't block on it.
blocking-basecamp: + → -
tracking-b2g18: --- → +
Josh, given our out-of-band communication, would you recommend holding the release for this bug?
blocking-basecamp: - → ?
Flags: needinfo?(jcarpenter)
(In reply to Chris Jones [:cjones] [:warhammer] from comment #9)
> Josh, given our out-of-band communication, would you recommend holding the
> release for this bug?

Nope. That specifically pertained to the behaviour seen when two-finger scrolling, and is a nice-to-fix.
Flags: needinfo?(jcarpenter)
blocking-basecamp: ? → -
Created attachment 698868 [details] [diff] [review]
Fix single pixel jitter on fling
Status: REOPENED → ASSIGNED
Comment on attachment 698868 [details] [diff] [review]
Fix single pixel jitter on fling

This seems to fix the problem but I haven't investigated why this rounding change is necessary.
Attachment #698868 - Attachment description: Bug 818482 - Fix single pixel jitter on fling; r=cjones → Fix single pixel jitter on fling
Attachment #698868 - Flags: review?(roc)
Comment on attachment 698868 [details] [diff] [review]
Fix single pixel jitter on fling

Review of attachment 698868 [details] [diff] [review]:
-----------------------------------------------------------------

Add a comment that we don't know why truncation is needed here.
Attachment #698868 - Flags: review?(roc) → review+
Created attachment 701322 [details] [diff] [review]
Remove rounding of scroll compensation in AZPC
Attachment #698868 - Attachment is obsolete: true
Attachment #701322 - Flags: review?(roc)
Comment on attachment 701322 [details] [diff] [review]
Remove rounding of scroll compensation in AZPC

Review of attachment 701322 [details] [diff] [review]:
-----------------------------------------------------------------

sweet
Attachment #701322 - Flags: review?(roc) → review+

Comment 16

5 years ago
Try run for a5d85dd1a190 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=a5d85dd1a190
Results (out of 28 total builds):
    success: 26
    warnings: 2
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-a5d85dd1a190
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/ed67c9f65a6d
Keywords: checkin-needed
Whiteboard: DUPEME
This patch is on top of 811950 so I will rebase it if 811950 doesn't get b2g18 approval.
https://hg.mozilla.org/mozilla-central/rev/ed67c9f65a6d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Comment on attachment 701322 [details] [diff] [review]
Remove rounding of scroll compensation in AZPC

Very safe patch that improves browser panning.  We'd like to take this for another reason too; ping me or Josh for details.
Attachment #701322 - Flags: approval-mozilla-b2g18?
status-b2g18: --- → affected
Comment on attachment 701322 [details] [diff] [review]
Remove rounding of scroll compensation in AZPC

low risk, high user benefit - approved for landing to branch, please land before 1/25 and mark the status flag as fixed once landed.
Attachment #701322 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
https://hg.mozilla.org/releases/mozilla-b2g18/rev/64bfbdb96823
status-b2g18: affected → fixed
status-firefox19: --- → wontfix
status-firefox20: --- → wontfix
status-firefox21: --- → fixed
You need to log in before you can comment on or make changes to this bug.