Status

()

--
critical
VERIFIED DUPLICATE of bug 81764
18 years ago
18 years ago

People

(Reporter: duffy151, Assigned: gordon)

Tracking

({crash})

Trunk
mozilla0.9.1
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
mozilla crashes when trying to load http://www.neaq.org/index2.html.  I *think*
it has something to do with allocating a new Image() in JavaScript and then
setting its src to something invalid. I'll attach a stripped down test case. I'm
not sure if this is ImageLib or a JS problem.  No talkback info because of bug
80852.

Steps to Reproduce:
1. Open http://www.neaq.org/index2.html

Actual Results:
mozilla crashes

Expected Results:
the page should load completely

Additional Information:
build id: 2001051821
(Reporter)

Comment 1

18 years ago
Created attachment 35323 [details]
Attached a test case

Comment 2

18 years ago
worksforme(url & test case), Linux, build 20010520 (06)

Comment 3

18 years ago
RH7.1, 2001052006
Loaded on first load, but all but one image was missing.
Forced a reload and crashed. Tested this several times - same crash on reload.
shift+reload or only reload eventually crashes in nsCacheEntry::GetData
Resembles backtrace in bug 81764

Comment 4

18 years ago
Created attachment 35327 [details]
backtrace

Updated

18 years ago
Severity: normal → critical
Keywords: crash

Comment 5

18 years ago
over to my good buddies in cache ;)
Assignee: pavlov → gordon
Component: ImageLib → Networking: Cache
QA Contact: tpreston → tever
(Assignee)

Comment 6

18 years ago


*** This bug has been marked as a duplicate of 81764 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Target Milestone: --- → mozilla0.9.1

Comment 7

18 years ago
verified dups
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.