Swipe to close tab action is sensitive

VERIFIED FIXED in Firefox 19

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: Paul Feher, Assigned: wesj)

Tracking

20 Branch
Firefox 20
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox18- unaffected, firefox19+ verified, firefox20 verified, fennec18+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Nightly 20.0a1 (2012-12-05)
Device: Samsung Galaxy SII
OS: Android 4.0.1

Steps to reproduce:
1. Open multiple tabs.
2. Swipe to close a few tabs. 

Expected:
The tab thumbnail should be closed after it covers a reasonable distance to avoid accidentally closing the tab.

Actual
The tab is closed almost instantly after the swipe action begins.
Ian, what do you think?

Updated

6 years ago
Summary: Swipe to close tab action is to sensitive → Swipe to close tab action is sensitive
This is an issue also on Firefox Mobile 18 beta 4. Here is a video from the Samsung Galaxy Tab 2 7.0 running Android 4.0.4: http://youtu.be/8d6hVhM3TTI
That video definitely looks a lot more sensitive than we want, I agree.

If we looked at the Android app switcher as a comparison, the threshold to close a tab seems to be roughly 25-30% the width of the screen. I feel like we did that originally for our tab tray too, did that get changed recently?
I also believe this to be a regression. Bug 764812 fixed this when the issue was first seen.

Updated

6 years ago
tracking-fennec: --- → ?
status-firefox18: --- → affected
status-firefox19: --- → affected
status-firefox20: --- → affected
Flags: needinfo?(wjohnston)
Wes, wasn't this fixed in 17?
(In reply to Aaron Train [:aaronmt] from comment #5)
> Wes, wasn't this fixed in 17?

No, this has been fixed in 19 (see bug 772940). This bug is a dup of bug 787335.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 787335
https://bugzilla.mozilla.org/show_bug.cgi?id=787335 has been verified fix. This issue is still reproducible on Nightly 20.0a1 2012-12-14.
Status: RESOLVED → REOPENED
Flags: needinfo?(wjohnston)
Resolution: DUPLICATE → ---
(Assignee)

Comment 8

6 years ago
Created attachment 693101 [details] [diff] [review]
Patch

getScaledMinimumFlingVelocity is actually a very very small number (62px/sec on my Nexus 7). The stock browser uses a larger number to determine this (1500/2). This feels a bit high to me tbh. 500 felt way too low. I decided to leave it here because I'd rather err on the hard side. Build at:

http://dl.dropbox.com/u/72157/fennec-slideClose.apk
Attachment #693101 - Flags: review?(lucasr.at.mozilla)
Comment on attachment 693101 [details] [diff] [review]
Patch

Review of attachment 693101 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.

::: mobile/android/base/TabsTray.java
@@ +343,5 @@
>          private int mSwipeThreshold;
>          private int mMinFlingVelocity;
> +        // same value the stock browser uses for after drag animation velocity in pixels/sec
> +        // http://androidxref.com/4.0.4/xref/packages/apps/Browser/src/com/android/browser/NavTabScroller.java#61
> +        private static final float MIN_VELOCITY = 750;

nit: move this to the top of the class.
Attachment #693101 - Flags: review?(lucasr.at.mozilla) → review+
tracking-fennec: ? → 18+
Assignee: nobody → wjohnston
nominate for tracking since this is an issue with a feature that was introduced in 18
tracking-firefox18: --- → ?
(Assignee)

Comment 12

6 years ago
Comment on attachment 693101 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Swipe to close rewrite (bug 772940)
User impact if declined: Swipe to close is very very easy to trigger
Testing completed (on m-c, etc.): landed on mc yesterday. i'd like to at least make sure UX has had a chance to test this, but it matches the stock browser behavior
Risk to taking this patch (and alternatives if risky): Very low risk. Changing a pref number
String or UUID changes made by this patch: None.
Attachment #693101 - Flags: approval-mozilla-beta?
Attachment #693101 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 13

6 years ago
Comment on attachment 693101 [details] [diff] [review]
Patch

I don't think that bug 772940 is actually in 18. Remove beta request.
Attachment #693101 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/a319fd7b88df
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
(Assignee)

Comment 15

6 years ago
Just wanted to make sure UX had played with this in nightlies and was ok with pushing this to Aurora.
Flags: needinfo?(madhava)
(Assignee)

Comment 16

6 years ago
UX says its good on irc!
Flags: needinfo?(madhava)

Updated

6 years ago
status-firefox18: affected → unaffected
tracking-firefox18: ? → -
tracking-firefox19: --- → +

Updated

6 years ago
Attachment #693101 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/f8b55879b2de
status-firefox19: affected → fixed
status-firefox20: affected → fixed
(Reporter)

Comment 18

6 years ago
Verified fixed on:
Nightly 20.0a1 (2013-01-02)
Aurora 19.0a2 (2013-01-02)
Status: RESOLVED → VERIFIED
status-firefox19: fixed → verified
status-firefox20: fixed → verified
You need to log in before you can comment on or make changes to this bug.