admin1.private.sfo1.mozilla.com failing to resolve address

RESOLVED INVALID

Status

Infrastructure & Operations
Infrastructure: Other
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: gene, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Something is going on with the SFO DNS server. This address, which resolves correctly at the gtld servers, fails to resolve at admin1.private.sfo1.mozilla.com.

This address resolved correctly yesterday (and all days before this) in SFO.

2012-12-05 09:39:25 ✔ gene@ruth:~$ dig cementhorizon.com NS @a.gtld-servers.net

; <<>> DiG 9.8.1-P1 <<>> cementhorizon.com NS @a.gtld-servers.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37726
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 3, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;cementhorizon.com.		IN	NS

;; AUTHORITY SECTION:
cementhorizon.com.	172800	IN	NS	ns1.rollernet.us.
cementhorizon.com.	172800	IN	NS	ns2.rollernet.us.
cementhorizon.com.	172800	IN	NS	ns6.cementhorizon.com.

;; ADDITIONAL SECTION:
ns6.cementhorizon.com.	172800	IN	A	204.246.122.113

;; Query time: 77 msec
;; SERVER: 192.5.6.30#53(192.5.6.30)
;; WHEN: Wed Dec  5 09:39:35 2012
;; MSG SIZE  rcvd: 117

2012-12-05 09:39:35 ✔ gene@ruth:~$ dig cementhorizon.com NS @10.251.75.5

; <<>> DiG 9.8.1-P1 <<>> cementhorizon.com NS @10.251.75.5
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 40606
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;cementhorizon.com.		IN	NS

;; Query time: 78 msec
;; SERVER: 10.251.75.5#53(10.251.75.5)
;; WHEN: Wed Dec  5 09:39:40 2012
;; MSG SIZE  rcvd: 35
(Reporter)

Comment 1

6 years ago
Something must be wrong with the registrar or with the domain because the same resolution failure is happening with google's public DNS servers (8.8.8.8)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Assignee: nobody → server-ops
Component: Networking: DNS → Server Operations
Product: Core → mozilla.org
QA Contact: shyam
Version: unspecified → other

Updated

6 years ago
Assignee: server-ops → server-ops-infra
Severity: normal → major
Component: Server Operations → Server Operations: Infrastructure
QA Contact: shyam → jdow

Updated

6 years ago
Severity: major → normal
(Reporter)

Comment 2

6 years ago
If anyone's curious, the cause was :
* Primary NS server for the domain had been down for 4 days
* Secondary NS servers gave up after 4 days and began returning "REFUSED" on requests

This scenario results in these somewhat confusing symptoms (gtld has records, resolvers in the world don't)
Component: Server Operations: Infrastructure → Infrastructure: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.