[B2G][Video] Crash occurs if user attempts to tap multiple times on a 00:00 length video in the Video App.

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Video
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: croesch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 688840 [details]
Crashing Video.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

1. Launch Build 20121204153445 Version: 18.0
2. Create a video in the Camera app that is 00:00 in length.
3. Exit the Camera app and launch the Video app.
4. Quickly Tap 3-4 times on the 00:00 video.
5. You should see that the video will fail to play and the Video app should crash.

Repro: 100%


Actual results:

The video will fail to play after the repeated tapping and the Video app will crash.


Expected results:

The Video app should handle the repeated tapping on the video gracefully.

Updated

5 years ago
Component: Gaia → Gaia::Video
QA Contact: mozillamarcia.knous

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
(Reporter)

Comment 1

5 years ago
Unagi Build 20130307070202
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/8feb4680772f
Gaia   fa5245750e7bb94b9f64180967536509316dedf5
Kernel Dec 5th

This issue is not occurring anymore. I can tap as often as I want on a video of 00:00 length with no problems. Resolving as works for me.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.