Perms Matrix vs. Installer - audio, system XHR, storage, cellbroadcast is undefined in the perms matrix

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jsmith, Assigned: sicking)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Permissions installer states the following:

231                            audio: {
232                              app: DENY_ACTION,
233                              privileged: ALLOW_ACTION,
234                              certified: ALLOW_ACTION,
235                              channels: ["normal", "content", "notification",
236                                "alarm", "telephony", "ringer", "publicnotification"]
237                            },

However, nothing is called out about this in the perms matrix. What's the story here?
(Reporter)

Updated

6 years ago
Blocks: 815565
Flags: needinfo?(jonas)
(Reporter)

Comment 1

6 years ago
Collapsing the bug per Jonas's feedback. Assigning to Gregor as he said he would handle these bugs.
Assignee: nobody → anygregor
Flags: needinfo?(jonas)
Summary: Perms Matrix vs. Installer - audio is undefined in the perms matrix → Perms Matrix vs. Installer - audio, system XHR, storage, cellbroadcast is undefined in the perms matrix
(Reporter)

Updated

6 years ago
Duplicate of this bug: 818599
(Reporter)

Updated

6 years ago
Duplicate of this bug: 818610
(Reporter)

Updated

6 years ago
Duplicate of this bug: 818613
(Reporter)

Updated

6 years ago
Summary: Perms Matrix vs. Installer - audio, system XHR, storage, cellbroadcast is undefined in the perms matrix → Perms Matrix vs. Installer - audio, system XHR, time, storage, cellbroadcast is undefined in the perms matrix
(Reporter)

Comment 5

6 years ago
Looks like time is okay here. Removing that from title.
Summary: Perms Matrix vs. Installer - audio, system XHR, time, storage, cellbroadcast is undefined in the perms matrix → Perms Matrix vs. Installer - audio, system XHR, storage, cellbroadcast is undefined in the perms matrix
I'll take this one to update the permission matrix where needed and will file bugs on any changes that are needed.
Assignee: anygregor → jonas
Flags: needinfo?(jonas)
Summary: Perms Matrix vs. Installer - audio, system XHR, storage, cellbroadcast is undefined in the perms matrix → Perms Matrix vs. Installer - audio, system XHR, device-storage:apps, cellbroadcast is undefined in the perms matrix
Sorry, ignore my summary edit.
Summary: Perms Matrix vs. Installer - audio, system XHR, device-storage:apps, cellbroadcast is undefined in the perms matrix → Perms Matrix vs. Installer - audio, system XHR, storage, cellbroadcast is undefined in the perms matrix
We went over this today and it actually looks like the code is in very good shape.

The "audio" permission needs some updates in the code, Lucas will file a bug on that.
The "systemXHR" permission looks fine in both code and the permission matrix. The two are in sync and contain the right policy.
"storage" just needed updating in the permission matrix. Code is fine.
"cellbroadcast" just needed clarification in the permission matrix. Code is fine.
"device-storage:apps" is now updated in the permissions matrix but needs code changes. Bug 818583 is filed on that.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(jonas)
Resolution: --- → FIXED
Ok so storage in the matrix doesnt match the installer, Ill raise a seperate bug.
You need to log in before you can comment on or make changes to this bug.