Installer displays percentages > 100%

VERIFIED FIXED

Status

SeaMonkey
Installer
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Blake Ross, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Installer just told me I was 102% done in file downloading.
(Assignee)

Comment 1

17 years ago
It looks like you're using the stub installer now.  Which build did this happen 
with?

My initial guess would be that the dummy talkback.xpi file is being replaced 
with a real talkback.xpi which is larger than the dummy one.  Since this 
replacing process is done after the installer build is done, the new size of the 
real talkback.xpi has not been taken into account.

(wait till you try using http:// protocol to download the files, you could hit 
204% :)  But that is a different bug)
Status: NEW → ASSIGNED
(Reporter)

Comment 2

17 years ago
This is 2001051920.  Right, it was getting talkback when I saw the problem.
(Assignee)

Comment 3

17 years ago
Created attachment 35341 [details] [diff] [review]
patch to fix the extra 2%
(Assignee)

Comment 4

17 years ago
Blake, could you could r= the trivial patch?  I simply hard coded the size 
values for the real talkback.xpi since it can't be calculated during the 
installer's build process.

The "Install Size Archive=248" (it used to be set to 2) is the one that will 
actually fix the 2%.  The other two values are used to make sure there's enought 
disk space available to install it.

Comment 5

17 years ago
i like having talkback be > 100%... it is more than you can get out of the 
mozilla source tree :)

r=leaf for the fix, if you *must* have accurate percentages.
(Reporter)

Comment 6

17 years ago
sr=blake

Comment 7

17 years ago
This is not fixed with the patch attached. Please take a look at the attached 
screenshots.

Comment 8

17 years ago
Created attachment 36629 [details]
200% in screenshot

Comment 9

17 years ago
Created attachment 36630 [details]
161% in screenshot
(Assignee)

Comment 10

17 years ago
Henrik, please file a different bug.  This bug refers to talkback, not http:// 
protocol.
(Assignee)

Comment 11

17 years ago
*** Bug 84447 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Blocks: 83989

Comment 12

17 years ago
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)
(Assignee)

Comment 13

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
Verified fixed on trunk build 2001070110 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.