Closed Bug 818715 Opened 8 years ago Closed 8 years ago

Moving cursor handle in input field causes keyboard to lock up

Categories

(Firefox for Android :: Keyboards and IME, defect)

ARM
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 20

People

(Reporter: bnicholson, Assigned: jchen)

Details

Attachments

(1 file)

STR:
1) Go to http://people.mozilla.com/~bnicholson/test/form.html
2) Click inside of the textarea to make the handle appear
3) Drag the handle around in circles for a few seconds
4) Try to type something

The keyboard is completely locked up and does not respond. I added logging to notifyIME() in GeckoAppShell, and it looks like we get loads of notifyIME messages sent when dragging the handle. Each time we move the handle, we generate a click in the text field, so we probably want to suppress IME notifications while we're positioning the cursor.
Assignee: nobody → nchen
We call restartInput on the InputMethodManager during each of the many notifyIME calls, and it tends to overwhelm the InputMethodManager. This patch coalesces the restartInput calls into 200ms bunches, so only one call is made within a 200ms period. I don't think delaying the call for 200ms would have big side effects, since the call is asynchronous anyways.
Attachment #691844 - Flags: review?(cpeterson)
Comment on attachment 691844 [details] [diff] [review]
Coalesce restartInput calls in GeckoInputConnection (v1)

Review of attachment 691844 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #691844 - Flags: review?(cpeterson) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/df953ce7ba31
Status: NEW → ASSIGNED
Flags: in-testsuite-
Target Milestone: --- → Firefox 20
https://hg.mozilla.org/mozilla-central/rev/df953ce7ba31
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Firefox 20.0a1 (2012-12-17)
Device: Galaxy Nexus
OS: Android 4.1.1

Using the following STR:
1) Go to http://people.mozilla.com/~bnicholson/test/form.html
2) Click inside of the textarea to make the handle appear
3) Drag the handle around in circles for a few seconds
4) Try to type something

I am not able to reproduce i. Marking bug as VERIFIED FIXED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.