panning immediately focuses text controls when the touch starts

RESOLVED DUPLICATE of bug 766066

Status

P3
normal
RESOLVED DUPLICATE of bug 766066
6 years ago
6 years ago

People

(Reporter: luke, Unassigned)

Tracking

({b2g-testdriver, unagi})

unspecified
x86_64
Linux
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
When I want to pan in an app, I shouldn't have to care what control is under my finger when I start panning.  Right now, if I start panning and my finger happens to start on a text control, the phone pulls up the keyboard and that breaks the entire pan and feels really wrong (based on my Android and iOS experience).  The problem is most heavily felt in the Contacts app where half the screen is text controls.

Note: this is also a problem for buttons, albeit a smaller one: if you start panning and your finger starts on a button, the button goes into the pressed state until you pan away.  I've found this visually jarring when, e.g., in the Settings app, every time I pan some random button gets highlighted.

For reference, this comes up and bothers me fairly often.
blocking-basecamp: ? → +
Priority: -- → P3
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766066
You need to log in before you can comment on or make changes to this bug.