OOM crash when scrolling a website with heavy images

RESOLVED WORKSFORME

Status

()

Core
XPCOM
--
critical
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: adminnu, Unassigned)

Tracking

({crash, reproducible})

Trunk
x86
Windows 7
crash, reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

103.92 KB, text/plain
Details
(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121205 Firefox/20.0
Build ID: 20121205030759

Steps to reproduce:

It starts up, the group had about 30 tabs, while the page loads, I closed the tab, closed 6 tabs appeared frieze window and moving to another tab, the browser is closed.


Actual results:

fell browser


Expected results:

all should be fine =((
(Reporter)

Updated

6 years ago
Severity: normal → critical
Crash Signature: [@ EMPTY: no crashing thread identified; corrupt dump ]
Keywords: crash
These are OOMing in string code:
xpcom_runtime_abort(###!!! ABORT: OOM: file e:\builds\moz2_slave\m-cen-w32-ntly\build\xpcom\string\src\nsTSubstring.cpp, line 348)

Comment 5

6 years ago
I don't see any crashes with the latest build.
Update your Nightly.
Is it reproducible? If yes, does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?
Flags: needinfo?(mail)

Comment 6

6 years ago
Launch Nightly 20.0 - before open tabs, check for 'Update Nightly' window pop up on the screen. If not, report the issue, because I see the updates for 'Nightly' every 2 days on and off...try to check for the updated build.

I never see this problem in Windows 7,64 OS

Detail the issue to solve better!
Thanks.
Flags: needinfo?(mail)

Updated

6 years ago
Flags: needinfo?(mail)
(Reporter)

Comment 7

6 years ago
I found the instructions in the appearance of a bug, if you open a long time to scroll http://eyecandy-girls.tumblr.com/, eventually does fall with the error:
https://crash-stats.mozilla.com/report/index/bp-8146a612-f40c-45db-9998-5f72f2121210
https://crash-stats.mozilla.com/report/index/bp-a5a92922-d0cf-4152-9f26-6cade2121210
Flags: needinfo?(mail)
(Reporter)

Comment 8

6 years ago
Check in safe mode and it flew https://crash-stats.mozilla.com/report/index/bp-16180db3-e716-4038-aea3-5c88b2121210 but much longer I had to scroll the page. Perhaps this is due to the fact that, along with Adblock it quickly becomes clogged.
(Reporter)

Updated

6 years ago
Depends on: 722083

Updated

6 years ago
Summary: crashes when working with tabs → [OOM? null dump] crashes when working with tabs

Comment 10

6 years ago
(In reply to adminnu from comment #8)
> Check in safe mode and it flew
> https://crash-stats.mozilla.com/report/index/bp-16180db3-e716-4038-aea3-
> 5c88b2121210 but much longer I had to scroll the page.
There's no OOM in this case.

(In reply to adminnu from comment #9)
> https://crash-stats.mozilla.com/report/
> list?signature=EMPTY%3A+no+crashing+thread+identified%3B+corrupt+dump
This crash signature is meaningless. It just means Firefox crashes in an unknown location.

Please provide a stack trace (see https://developer.mozilla.org/docs/How_to_get_a_stacktrace_with_WinDbg).

Updated

6 years ago
Flags: needinfo?(mail)
Keywords: stackwanted

Updated

6 years ago
Crash Signature: [@ EMPTY: no crashing thread identified; corrupt dump ]

Updated

6 years ago
No longer depends on: 722083

Comment 11

6 years ago
Please leave this signature on the bug, it's one case that triggers crashes with that null dump signature, so we really want it to be connected with it. Something happens there so that the Windows function to generate a minidump fails - you're right that this isn't helpful in telling us what happened, but it's still info I want to have tracked.
Crash Signature: [@ EMPTY: no crashing thread identified; corrupt dump ]
(Reporter)

Comment 12

6 years ago
Of course, the initial departure was due to another, now try to scrolling.
Flags: needinfo?(mail)
(Reporter)

Comment 13

6 years ago
Created attachment 690370 [details]
debug log

hope to do it right

Comment 14

6 years ago
(In reply to adminnu from comment #7)
> I found the instructions in the appearance of a bug, if you open a long time
> to scroll http://eyecandy-girls.tumblr.com/, eventually does fall with the
> error:
It crashes for me also: bp-fdc02ab8-5156-45f7-bd95-aec002121210.

(In reply to adminnu from comment #13)
> hope to do it right
It seems good. It has the same signature as bug 764342.
Blocks: 764342
Status: UNCONFIRMED → NEW
Crash Signature: [@ EMPTY: no crashing thread identified; corrupt dump ] → [@ EMPTY: no crashing thread identified; corrupt dump ] [@ mozalloc_abort(char const* const) | mozalloc_handle_oom(unsigned int) | moz_xmalloc | nsSegmentedBuffer::AppendNewSegment()]
Component: Untriaged → XPCOM
Ever confirmed: true
Keywords: stackwanted → reproducible
Product: Firefox → Core
Hardware: x86_64 → x86
Summary: [OOM? null dump] crashes when working with tabs → OOM crash when scrolling a website with heavy images
Version: 20 Branch → Trunk

Comment 15

5 years ago
Does it happen in today's nightly that contains the fix of bug 689623?
Flags: needinfo?(mail)

Comment 16

5 years ago
(In reply to Scoobidiver from comment #15)
> Does it happen in today's nightly that contains the fix of bug 689623?

WFM with 23.0a1 (2013-05-13)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mail)
Resolution: --- → WORKSFORME

Comment 17

5 years ago
adminnu can you still reproduce crash?


(In reply to Wayne Mery (:wsmwk) from comment #16)
> (In reply to Scoobidiver from comment #15)
> > Does it happen in today's nightly that contains the fix of bug 689623?
> 
> WFM with 23.0a1 (2013-05-13)

WFM meaning I don't crash. But it still sucks memory
Flags: needinfo?(mail)
Played around with the site, it definitely does use a lot of memory, but it does not appear to be due to decoded image data.

Updated

4 years ago
Flags: needinfo?(mail)
You need to log in before you can comment on or make changes to this bug.