Closed Bug 818871 Opened 7 years ago Closed 4 years ago

Fillit App doesn't work properly on Android

Categories

(Firefox for Android :: Toolbar, defect, P5)

19 Branch
All
Android
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
fennec + ---

People

(Reporter: eviljeff, Unassigned)

References

()

Details

(Whiteboard: [webcompat])

The Fillit app doens't work properly on Firefox for Android, but does on Desktop and FxOS.
On a mobile I couldn't see the start button at all - on Tablet the button was visible at the top of the screen but after pressing it the game sprites don't move as they should.

App should be installable from the link below shortly (I'm approving it for Desktop and Firefox) but can otherwise be seen here: http://subfillit.dseffects.com/Fillit.php?pid=6900
What happens if you change the user agent to FF OS on Fx Android and try using the app?

Want to confirm if this is a user agent issue or not.
No difference (I used the Phony addon to adjust it).
tracking-fennec: --- → ?
(In reply to Andrew Williamson [:eviljeff] from comment #2)
> No difference (I used the Phony addon to adjust it).

What UA did you use?
(In reply to Mark Finkle (:mfinkle) from comment #3)
> (In reply to Andrew Williamson [:eviljeff] from comment #2)
> > No difference (I used the Phony addon to adjust it).
> 
> What UA did you use?

the one labelled Firefox OS - looks like Mozilla/5.0 (Mobile; rv:12.0) Gecko/12.0 Firefox 12.0
I see some really odd navigator detection code on the page; beats me on what's it's trying to do though

if(navigator.userAgent.indexOf("Silk")!=-1){navigator.__defineGetter__("userAgent", function(){return "Mozilla/ 5.0 (Linux; Android 4.0.4; Tablet";});navigator.userAgent;
(In reply to Aaron Train [:aaronmt] from comment #5)
> I see some really odd navigator detection code on the page; beats me on
> what's it's trying to do though
> 
> if(navigator.userAgent.indexOf("Silk")!=-1){navigator.
> __defineGetter__("userAgent", function(){return "Mozilla/ 5.0 (Linux;
> Android 4.0.4; Tablet";});navigator.userAgent;

Silk is the Amazon's browser on its tablets, isn't it?
Haha, it looks like they're monkeypatching the javascript UA string when the silk browser is used to make it look like a regular android tablet. They probably have some other libraries later on that don't have special code paths for silk and they're trying to fool that code into taking the normal android codepath tablet. Programs... hacking.. programs!
Whiteboard: [webcompat]
tracking-fennec: ? → -
Component: Graphics, Panning and Zooming → Evangelism
I don't understand why the component has changed to Evangelism - regardless of their odd UA sniffing for Amazon's tablets, its not working on Android but is on Desktop and FxOS.
Flags: needinfo?(blassey.bugs)
I took it to be a UA sniffing problem. If that's not the case change the component back and renom for tracking with an explanation.
Flags: needinfo?(blassey.bugs)
UA Sniffing only affects Silk browser so shouldn't affect browser behaviour on Android v. FxOS.
tracking-fennec: - → ?
Component: Evangelism → Graphics, Panning and Zooming
Duplicate of this bug: 822668
tracking-fennec: ? → +
filter on [mass-p5]
Priority: -- → P5
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.