crash [@mozilla::widget::winrt::FrameworkView::UpdateSizeAndPosition]

RESOLVED DUPLICATE of bug 853482

Status

Firefox for Metro
Browser
--
critical
RESOLVED DUPLICATE of bug 853482
6 years ago
4 years ago

People

(Reporter: juanb, Unassigned)

Tracking

({crash})

Trunk
x86_64
Windows 8.1
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME][metro-crash], crash signature)

(Reporter)

Description

6 years ago
https://crash-stats.mozilla.com/report/index/6bdf2c2c-56ee-4d2f-bee3-09b2b2121206

I got a crash when launching Firefox using the tile while the browser was already running in the desktop.

Steps:
1. Launching using ...Nightly/firefox.exe -metrodesktop
- In this case the browser launched in in a window in desktop mode, although it looks like the tablet browser
2. Click on the Windows key and then attempt to launch Firefox using the tile

Expected: Firefox launches in Metro mode

Actual: Some kind of blank page appears briefly then it reverts to displaying all the tiles.

If you attempt to relaunch after a while, it does launch in Metro mode and you get a message "oh noooz, you crashed."

I did not attempt to reproduce.
(Reporter)

Updated

6 years ago
Whiteboard: DUPUME

Updated

6 years ago
Crash Signature: [@ mozilla::widget::winrt::FrameworkView::UpdateSizeAndPosition()]
Keywords: crash

Updated

6 years ago
OS: Windows 8 → Windows 8 Metro

Updated

6 years ago
Severity: normal → critical

Comment 1

6 years ago
This looks pretty easy to fix. startup times are all low, implying a startup crash. Looks like we get a resize event before the base widget has been created.

http://hg.mozilla.org/mozilla-central/annotate/885cde564ff3/widget/windows/winrt/FrameworkView.cpp#l273
Blocks: 844608

Updated

6 years ago
Whiteboard: DUPUME → [DUPEME][metro-crash]

Updated

5 years ago
No longer blocks: 844608

Updated

5 years ago
Blocks: 855294

Updated

5 years ago
Depends on: 853482

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 853482

Updated

5 years ago
No longer depends on: 853482
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.