Update ar, fr, zh-TW in git

RESOLVED FIXED in B2G C3 (12dec-1jan)

Status

P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: stas, Assigned: Pike)

Tracking

unspecified
B2G C3 (12dec-1jan)
x86_64
Linux

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: QARegressExclude)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
This will fix the issue from bug 818015 and probably many others.

This is not required to ship the final product. The purpose of this patch is to make it easier for developers to get started just by cloning mozilla-b2g/gaia. We want them to start with a somewhat-up-to-date set of locales to test localizability and internationalization.

The real infrastructure to build multilocale Gaia is being tracked in bug 766962.
(Reporter)

Comment 1

6 years ago
Created attachment 689306 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6863

Pointer to Github pull-request
(Reporter)

Comment 2

6 years ago
Comment on attachment 689306 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6863

Unfortunately this pull request changes the ordering of keys in manifest.webapp files. This is a one-time change, it will get easier next time :)

What do you think, kazé?
Attachment #689306 - Flags: review?(kaze)
(In reply to Staś Małolepszy :stas (offline Dec 7-Dec 16) from comment #2)\
> Unfortunately this pull request changes the ordering of keys in
> manifest.webapp files. 

I don’t object ordering keys alphabetically but I think it’d be better to keep at least these properties on top of the manifest files: name, description, launch_path (and then, other keys in alphabetical order).

Can you rebase your PR please?
Staś: worst case, I’d be fine with a git update that leaves manifest.webapp files alone in the short term.
Axel, would you steal this bug please?
Flags: needinfo?(l10n)
Comment on attachment 689306 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6863

Please ignore manifests until you can keep the main properties on top of the files.
Attachment #689306 - Flags: review?(kaze) → review-
(Assignee)

Comment 7

6 years ago
I'm working on an update.

Do you mind if I shuffle the locales and file order inside the locales.ini? It's much easier to write them out sorted alphabetically the trying to write a parser that can carry forward the edits in a minimal way.
Assignee: nobody → l10n
Flags: needinfo?(l10n)
The files inside the `locales.ini` *should* be sorted alphabetically anyway, so be my guest. :)
(Assignee)

Comment 9

6 years ago
Created pull request https://github.com/mozilla-b2g/gaia/pull/6986, not sure how to get them to an attachment.
Axel: you can copy/paste this HTML fragment [1], make it point to your pull request, send it as an attachment and put me in r?.

[1] https://bugzilla.mozilla.org/attachment.cgi?id=689306&action=edit
I just had a quick glance, it looks OK but the Arabic locale is missing. Ain’t there any update at all on the [ar] front?
Asking BB+ here because we need this to test the UI with various string lengths. I expect that a few CSS adjustments will be required to be i18n-safe…
blocking-basecamp: --- → ?
(Assignee)

Comment 13

6 years ago
Created attachment 691556 [details]
github pull request for french and chinese

There hasn't been an update to arabic, so, no changes there, just french an zh-TW.
Attachment #689306 - Attachment is obsolete: true
Attachment #691556 - Flags: review?(kaze)
Comment on attachment 691556 [details]
github pull request for french and chinese

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): removal of 10n resources from the gaia repo
User impact if declined: cannot test Gaia with non-English locales
Testing completed: manual
Risk to taking this patch (and alternatives if risky): none, l10n only
Attachment #691556 - Flags: review?(kaze)
Attachment #691556 - Flags: review+
Attachment #691556 - Flags: approval-gaia-master?(21)
Triage: BB+, C3, P1 - late l10n
blocking-basecamp: ? → +
Keywords: late-l10n
Priority: -- → P1
Target Milestone: --- → B2G C3 (12dec-1jan)
https://github.com/mozilla-b2g/gaia/commit/bc8d8cb58456ef24e929fac879a4476e8e6e0224
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 18

6 years ago
Removing late-l10n keyword, as this doesn't have an impact on our localization efforts.
Keywords: late-l10n
May I ask how/who did the french locale for geoloc application ?

Especially this one:
-gps-fixes = Positions
-last-fix = Dernier
+gps-fixes = Corrections
+last-fix = Dernière
(Assignee)

Comment 20

6 years ago
Theo changed that, see http://hg.mozilla.org/gaia-l10n/fr/rev/530ee013c53f.

This is gonna uplift into the gaia repo itself eventually.

Updated

6 years ago
Whiteboard: QARegressExclude
You need to log in before you can comment on or make changes to this bug.