Request for gum audio for integrated mic in one tab, USB mic in second tab - sound becomes distorted

RESOLVED WORKSFORME

Status

()

Core
WebRTC: Audio/Video
P2
normal
Rank:
29
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Steps:

1. Load the attached test case in two tabs with a USB mic and integrated mic hooked in
2. Request audio for integrated mic in first tab
3. Request audio for USB mic in second tab

Expected:

Both input sources become active and sound should come in clear.

Actual:

Both input sources become active, but the sound becomes somewhat distorted. Maybe it's two input sources separately competing with one another?
(Reporter)

Updated

5 years ago
Summary: Request for audio for integrated mic in one tab, USB mic in second tab - sound becomes distorted → Request for gum audio for integrated mic in one tab, USB mic in second tab - sound becomes distorted
(Reporter)

Updated

5 years ago
Whiteboard: [getUserMedia] [blocking-gum-]
Juan - can you recheck this bug?  I suspect it's (long) resolved...
Flags: needinfo?(jbecerra)
Whiteboard: [getUserMedia] [blocking-gum-]
backlog: --- → webRTC+
Rank: 29
Priority: -- → P2

Updated

3 years ago
Blocks: 1173020

Updated

3 years ago
No longer blocks: 1173020
I tested this on Nightly(41) and Firefox Developer Edition(40) and I was not able to reproduce the problem as described.

However I did notice that the volume is very high in the first 2 or 3 seconds, and it eventually normalizes. 

This doesn't happen when sharing the mics individually.

Marking this as resolved works for me, because although there's this slight loud noise in the beginning, the audio is not distorted. Opening bug 1173020 for that other issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jbecerra)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.