If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Request gum audio in one tab for integrated mic, USB mic in second tab, call stop() in first tab - integrated mic is still active

RESOLVED WORKSFORME

Status

()

Core
WebRTC: Audio/Video
P1
normal
Rank:
19
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [getUserMedia], [blocking-gum-])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 689312 [details]
Testcase

Steps:

1. Load the attached test case in tab #1 and tab #2 with a USB + integrated mic hooked in
2. Accept permissions in tab #1 with the integrated mic
3. Accept permissions in tab #2 with the USB mic
4. Call stop() on tab #1

Expected:

Only the USB mic should be a valid input source.

Actual:

Both input sources remain active.
(Reporter)

Comment 1

5 years ago
Test on OS X and a different windows box - qawanted.
Keywords: qawanted

Updated

5 years ago
Assignee: nobody → jsmith
Whiteboard: [getUserMedia], [blocking-gum-]
(Reporter)

Comment 2

5 years ago
Confirmed now on multiple machines. I just tested this on OS X 10.7 and confirmed this to reproduce generally.
Assignee: jsmith → nobody
Keywords: qawanted
Juan -- Can you retest this?  I believe this was fixed a while ago.
Rank: 19
Flags: needinfo?(jbecerra)
Priority: -- → P1
QA Contact: jsmith
backlog: --- → webRTC+
I'm not able to reproduce this on my Windows machine using nightly or Fx dev edition. I also tested on Mac.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jbecerra)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.