If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent browser_ApplicationPrefs.js, dom-mutations-ref.html, test_transitions_per_property.html [@ proxy_TraceObject] ("Assertion failure: *p->value.unsafeGet() == ObjectValue(*obj), at ../../../../js/src/jsproxy.cpp:2838")

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({assertion, crash, intermittent-failure})

Trunk
x86
Windows XP
assertion, crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
Rev3 WINNT 5.1 mozilla-inbound debug test mochitest-browser-chrome on 2012-12-03 02:06:09 PST for push b3b4311176fa

slave: talos-r3-xp-014

https://tbpl.mozilla.org/php/getParsedLog.php?id=17552341&tree=Mozilla-Inbound

{
INFO TEST-END | chrome://mochitests/content/browser/browser/fuel/test/browser_ApplicationPrefs.js | finished in 1216ms
TEST-INFO | checking window state
Assertion failure: *p->value.unsafeGet() == ObjectValue(*obj), at e:/builds/moz2_slave/m-in-w32-dbg/build/js/src/jsproxy.cpp:2838
nsStringStats
 => mAllocCount:        4990227
 => mReallocCount:       207059
 => mFreeCount:         4943951  --  LEAKED 46276 !!!
 => mShareCount:       10628795
 => mAdoptCount:         353807
 => mAdoptFreeCount:     353801  --  LEAKED 6 !!!
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/fuel/test/browser_ApplicationPrefs.js | Exited with code -2147483645 during test run
INFO | automation.py | Application ran for: 0:58:50.984000
INFO | automation.py | Reading PID log: c:\docume~1\cltbld\locals~1\temp\tmp6uk5vhpidlog
==> process 4000 launched child process 4072
==> process 4000 launched child process 1324
INFO | automation.py | Checking for orphan process with PID: 4072
INFO | automation.py | Checking for orphan process with PID: 1324
Downloading symbols from: http://ftp-scl3.mozilla.com/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32-debug/1354526081/firefox-20.0a1.en-US.win32.crashreporter-symbols.zip
PROCESS-CRASH | chrome://mochitests/content/browser/browser/fuel/test/browser_ApplicationPrefs.js | application crashed [@ proxy_TraceObject]
Crash dump filename: c:\docume~1\cltbld\locals~1\temp\tmp3cowkq\minidumps\99e96702-5851-4055-83dc-4becfbf3d879.dmp
Operating system: Windows NT
                  5.1.2600 Service Pack 2
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXCEPTION_BREAKPOINT
Crash address: 0xbc4ea2

Thread 0 (crashed)
 0  mozjs.dll!proxy_TraceObject [jsproxy.cpp:b3b4311176fa : 2838 + 0x52]
    eip = 0x00bc4ea2   esp = 0x0012d7a0   ebp = 0x0012d7c4   ebx = 0xffffff87
    esi = 0x3db125b0   edi = 0x10261440   eax = 0x00000000   ecx = 0x64a87655
    edx = 0x10361f48   efl = 0x00200216
    Found by: given as instruction pointer in context
 1  mozjs.dll!js::GCMarker::processMarkStackTop(js::SliceBudget &) [Marking.cpp:b3b4311176fa : 1364 + 0xc]
    eip = 0x00daf010   esp = 0x0012d7cc   ebp = 0x0012d814
    Found by: call frame info
 2  mozjs.dll!js::GCMarker::drainMarkStack(js::SliceBudget &) [Marking.cpp:b3b4311176fa : 1408 + 0x7]
    eip = 0x00daf838   esp = 0x0012d81c   ebp = 0x0012d830
    Found by: call frame info
 3  mozjs.dll!IncrementalCollectSlice [jsgc.cpp:b3b4311176fa : 3835 + 0x29]
    eip = 0x00b04c65   esp = 0x0012d838   ebp = 0x0012d880
    Found by: call frame info
 4  mozjs.dll!GCCycle [jsgc.cpp:b3b4311176fa : 4006 + 0x14]
    eip = 0x00b05c6a   esp = 0x0012d888   ebp = 0x0012d8c0
    Found by: call frame info
 5  mozjs.dll!Collect [jsgc.cpp:b3b4311176fa : 4124 + 0x1d]
    eip = 0x00b060c3   esp = 0x0012d8c8   ebp = 0x0012d908
    Found by: call frame info
 6  mozjs.dll!js::GCSlice(JSRuntime *,js::JSGCInvocationKind,js::gcreason::Reason,__int64) [jsgc.cpp:b3b4311176fa : 4162 + 0x11]
    eip = 0x00b062fc   esp = 0x0012d910   ebp = 0x0012d92c
    Found by: call frame info
 7  mozjs.dll!js::IncrementalGC(JSRuntime *,js::gcreason::Reason,__int64) [jsfriendapi.cpp:b3b4311176fa : 190 + 0x16]
    eip = 0x00ace5ca   esp = 0x0012d934   ebp = 0x0012d948
    Found by: call frame info
 8  xul.dll!nsJSContext::GarbageCollectNow(js::gcreason::Reason,nsJSContext::IsIncremental,nsJSContext::IsCompartment,nsJSContext::IsShrinking,__int64) [nsJSEnvironment.cpp:b3b4311176fa : 2918 + 0x14]
    eip = 0x0239511a   esp = 0x0012d950   ebp = 0x0012d970
}
Comment hidden (Treeherder Robot)
Summary: Intermittent crash in browser_ApplicationPrefs.js [@ proxy_TraceObject] ("Assertion failure: *p->value.unsafeGet() == ObjectValue(*obj), at e:/builds/moz2_slave/m-in-w32-dbg/build/js/src/jsproxy.cpp:2838") → Intermittent crash in browser_ApplicationPrefs.js, dom-mutations-ref.html [@ proxy_TraceObject] ("Assertion failure: *p->value.unsafeGet() == ObjectValue(*obj), at e:/builds/moz2_slave/m-in-w32-dbg/build/js/src/jsproxy.cpp:2838")
Duplicate of this bug: 824209
Summary: Intermittent crash in browser_ApplicationPrefs.js, dom-mutations-ref.html [@ proxy_TraceObject] ("Assertion failure: *p->value.unsafeGet() == ObjectValue(*obj), at e:/builds/moz2_slave/m-in-w32-dbg/build/js/src/jsproxy.cpp:2838") → Intermittent browser_ApplicationPrefs.js, dom-mutations-ref.html, test_transitions_per_property.html [@ proxy_TraceObject] ("Assertion failure: *p->value.unsafeGet() == ObjectValue(*obj), at ../../../../js/src/jsproxy.cpp:2838")
Comment hidden (Treeherder Robot)
Keywords: assertion
Since talos-r4-snow-029 and talos-r4-lion-039 are both known-bad, chances are the only thing this bug has to say is "talos-r3-xp-014 is probably defective too."
this seems to be a real issue, bughunter also reported this on linux and beta branch

--DOCSHELL 0x1ace9f0 == 0 [id = 3]
WARNING: nsExceptionService ignoring thread destruction after shutdown: file /work/mozilla/builds/beta/mozilla/xpcom/base/nsExceptionService.cpp, line 167
Assertion failure: *p->value.unsafeGet() == ObjectValue(*obj), at /work/mozilla/builds/beta/mozilla/js/src/jsproxy.cpp:3016
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 9

4 years ago
Comment 8 was a mis-star, marking WFM for now to avoid future confusion.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.