Closed Bug 819050 Opened 7 years ago Closed 6 years ago

Marionette response containing element has raw ID instead of JSON object

Categories

(Testing :: Marionette, defect)

18 Branch
defect
Not set

Tracking

(firefox26 fixed, firefox27 fixed)

RESOLVED FIXED
mozilla27
Tracking Status
firefox26 --- fixed
firefox27 --- fixed

People

(Reporter: james.h.evans.jr, Assigned: automatedtester)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

After properly establishing a session, navigate to a page containing an element with the id attribute set to '2'. Execute the following command via Marionette, substituting the appropriate values for your session.

{"to":"conn0.marionette1","type":"findElement","session":"8","using":"id","value":"2"}


Actual results:

I received the following response:

{
  "from": "conn0.marionette1",
  "value": "{db9ca612-a761-4085-85d0-62a7b6144b05}"
}


Expected results:

I should receive the following response:

{
  "from": "conn0.marionette1",
  "value": 
  {
    "ELEMENT": "{db9ca612-a761-4085-85d0-62a7b6144b05}"
  }
}

Every other WebDriver-compliant server component returns element references in this way. It ensures that when the executeScript command is called, the client can tell the difference between an element reference returned by the JavaScript function, and a string that just happens to look like an internal WebDriver element ID.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This will be slightly tricky to fix, since it will require synchronized changes to both client and server.   But, we need it for webdriver compatibility.
Assignee: nobody → jgriffin
Assignee: jgriffin → dburns
Blocks: 807282
Attachment #811336 - Flags: review?(mdas)
Attachment #811336 - Flags: review?(mdas) → review+
Attached patch bug819050.patchSplinter Review
Attaching rebased patched and carrying r+ forward
Attachment #811336 - Attachment is obsolete: true
Attachment #817087 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/772c99944a84
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.