Closed Bug 819070 Opened 8 years ago Closed 8 years ago

Going back from Awesomescreen opens additional tabs when "Don't keep activities" is enabled

Categories

(Firefox for Android Graveyard :: Awesomescreen, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox17 unaffected, firefox18 unaffected, firefox19 verified, firefox20 verified)

VERIFIED FIXED
Firefox 20
Tracking Status
firefox17 --- unaffected
firefox18 --- unaffected
firefox19 --- verified
firefox20 --- verified

People

(Reporter: jchen, Assigned: bnicholson)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

1. Enable "Don't keep activities" in Settings > Developer options (ICS/JB)
2. Open Nightly
3. Tap on Awesomebar to open Awesomescreen
4. Press Back button to return to home.



Actual results:

Multiple about:home tabs are opened (Tab count changes to 3)


Expected results:

No additional about:home tabs are opened (Tab count stays at 1)
Only reproducible on Aurora and Nightly; not reproducible on Beta and Release.
OS: Mac OS X → Android
Hardware: x86 → ARM
Brian - Could we be restoring session somehow?
Guards the session restore code with "if (!mIsRestoringActivity)", which prevents the restore from happening if Gecko has already been initialized.
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Attachment #689490 - Flags: review?(mark.finkle)
Blocks: 722661
Attachment #689490 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/eb15961f3b3e
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Comment on attachment 689490 [details] [diff] [review]
Don't restore session if Gecko is already running

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 722661 (Fx19)
User impact if declined: Using "Don't keep activities" can result in duplicate tabs being created
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #689490 - Flags: approval-mozilla-aurora?
Comment on attachment 689490 [details] [diff] [review]
Don't restore session if Gecko is already running

Low risk patch for a Fx 19 regression. Approving on Aurora.
Attachment #689490 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
Unable to reproduce the issue anymore on Aurora 20.0a2 2013-01-10 and Nightly 21.0a1 2013-01-10 on the Samsung Galaxy Note running Android 4.0.4. Marking the bug as verified on Firefox Mobile 20
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.