Persona password resets not delivered to mozilla.com alias

RESOLVED FIXED

Status

Infrastructure & Operations
Infrastructure: Other
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: erik, Assigned: gene)

Tracking

Details

(Reporter)

Description

6 years ago
I've been trying to reset the Persona (https://login.persona.org/) password for my erik att mozilla.com alias, but I never get the password-reset emails. I get them at my personal colo and at my base "erose at mozilla.com" account--it's just the alias that never sees delivery (20 hours and counting). The alias does receive other mail just fine. I'm a bit flummoxed.
Assignee: server-ops → server-ops-infra
Component: Server Operations → Server Operations: Infrastructure
QA Contact: shyam → jdow

Comment 1

6 years ago
Do you have a time that you tried to do a reset password? I do indeed see all the other emails to erik [at] mozilla.com going through so a time frame would be great to narrow this down a little

Comment 2

6 years ago
Check Postini. :atoll was telling me last night that this is actually a common and known thing with Persona that services ops is working on.
(Reporter)

Comment 3

6 years ago
Good thought, but I checked Postini yesterday, and that's not it.

Here, I just sent another one: 10:38:13 Pacific.

Comment 4

6 years ago
Hmm not seeing anything in the mail logs during that period as well, and indeed there is no emails in the quarantine.
(Reporter)

Comment 5

6 years ago
Maybe it's some kind of weird Persona bug after all.
There appears to be no erik@mozilla.com in postini.  In theory not having an account means mail to that address isn't supposed to be filtered at all, but I've heard mixed stories about this.  There certainly isn't a quarantine to put it in if Postini doesn't know about the account.  I just added erik as an alias to erose in Postini, so if Postini is actually snagging it, the next attempt should show up in your quarantine.
(Reporter)

Comment 7

6 years ago
Another good thought. I sent another reset email at about 15:23 Pacific, but I haven't seen anything in postini or my mailbox after 6 minutes. Hmm.
(In reply to Justin Dow [:jabba] from comment #2)
> Check Postini. :atoll was telling me last night that this is actually a
> common and known thing with Persona that services ops is working on.

It is a common (every @m.c user that's tried so far) and known (to some/all identity devs and ops), but I don't know for certain whether it's Postini or some other step in the MTA chain discarding those mails.
We run persona don't we?  Can we get someone to look at Persona's outbound logs and see where they're sending it?
(In reply to Dave Miller from comment #9)
> We run persona don't we?  Can we get someone to look at Persona's outbound
> logs and see where they're sending it?

Services Operations would have more information about the Socketlabs delivery failures.
Flags: needinfo?(gene)
(Assignee)

Comment 11

6 years ago
We use Socketlabs to deliver email from Persona to users. Their activity logs don't go back far enough to catch the emails from the beginning of December.

Erik, can you attempt again and let me know the result and the date/time that the email would have been sent?
Flags: needinfo?(gene) → needinfo?(erik)
(Assignee)

Updated

6 years ago
Assignee: server-ops-infra → gene
(Reporter)

Comment 12

6 years ago
Sent myself a new password-reset mail at 13:00:25 Pacific. Received it! Hooray!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(erik)
Resolution: --- → FIXED
Component: Server Operations: Infrastructure → Infrastructure: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.