Refreshing a secure page after entering valid credentials does not force the user to reenter their credentials

VERIFIED INVALID

Status

Firefox OS
Gaia::Browser
VERIFIED INVALID
5 years ago
5 years ago

People

(Reporter: CKreinbring, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

1. Launch the browser app.
2. Navigate to a secure site that will require the user to log in (eg gmail.com).
3. Enter valid credentials then sign in.
4. Wait for the page to finish loading, then tap the refresh button in the address bar.
5. Observe the state of the page as it reloads.


Actual results:

The page refreshes, showing the same post-login page.


Expected results:

The page refreshes and shows the log in page, requiring the user to reenter their credentials.
Is this another test case? It makes no sense. This sounds like the correct behaviour to me.
(Reporter)

Comment 2

5 years ago
(In reply to Ben Francis [:benfrancis] from comment #1)
> Is this another test case? It makes no sense. This sounds like the correct
> behaviour to me.

Yes, this is based off of the Browser test case "Test that Refresh a webpage when the end-user has filled a form".  Its ID is #1748.
Naoki, can you figure out what this test case is really trying to test? This bug as filed seems invalid.

Thanks
Flags: needinfo?(nhirata.bugzilla)
I get the feeling that a step is missed in the test case of clearing the data from the settings button.  I'll look into it further.
Flags: needinfo?(nhirata.bugzilla)
Oh!  Turns out that it's more of a form fill not a login fill.

We want to make sure that invalidation for the form occurs, not the login itself.  Moving the test case to draft for revision purposes.  This is invalid as stated due to the invalid test case.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.