Configuration is reset after browser crash

RESOLVED WORKSFORME

Status

()

Toolkit
Preferences
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Fred Yontz, Unassigned)

Tracking

17 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Restarted Firefox 17.0.1 after it crashed.


Actual results:

My customized toolbar configuration was reset to installation default.


Expected results:

My toolbar configuration should have remained the same as I had configured it, just as it did for many prior versions.
(Reporter)

Comment 1

5 years ago
This configuration reset happened again a few minutes ago, after another Firefox 17.0.1 crash.

To determine if this is a characteristic of version 17.0.1 I've adjusted extensions to be compatible with version 16.0.2 and I'm reverting to using that, and waiting for another crash.  (I adjusted extensions before this latest crash.)  I will report further when the next crash (v. 16.0.2) occurs.
(Reporter)

Comment 2

5 years ago
I tried reverting to Firefox 16.0.2, and when it finally crashed I found that it, too, was resetting my configuration to the default state.

This is a new phenomenon in my experience. I've had many Firefox crashes in the past, but only recently have I lost all my configuration settings — toolbars in view, positions of control buttons, etc. — after a crash. And since Firefox seems to be crashing more frequently, often with just a couple of windows and a couple dozen tabs open, it appears to be losing its former robustness.  I wish I knew where the chrome configuration data is stored, so I could just save and restore that data in the event of a crash.

Updated

5 years ago
Component: Untriaged → Toolbars

Updated

5 years ago
Component: Toolbars → Session Restore
(Reporter)

Comment 3

5 years ago
Interesting side note, not totally connected to this issue:  when I updated to the latest version (Firefox 19.0 with 3 windows & 95 tabs), it crashed within minutes, and upon two restarts, repeated the immediate crashing. (I'll file a separate bug on this.)

Having had some problems with recent versions, I reverted to Firefox 12.0 to see whether it would also crash, and if it did would it also reset my configuration. It's been over a week now, and using the same windows & tabs load, it hasn't crashed at all. 

My conclusion is that more recent versions of Firefox have lost stability and are more fragile. In comparison, my installation of SeaMonkey (now at v2.16 and with 3 windows & 65 tabs) has been rock solid through several updates.

Comment 4

4 years ago
toolbar info is not part of session restore
Component: Session Restore → Preferences
Product: Firefox → Toolkit
(Reporter)

Comment 5

4 years ago
My thought is that if toolbar configurations are not restored, since they are such an important part of what a browser is and how it presents itself to a user, that is a serious omission, and it's hard for me to say a session has been restored if I find myself with a significantly altered browser.

All that aside, I'm happy to report that I haven't had further instances of this problem.  At Firefox 26.0, I still find it crashing more often than a couple years ago, making me wonder if added features and complexity has also added fragility, but it appears that the problem I raised has become resolved, however mysteriously so, and this bug should be closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.