[Clock] The alarm attention screen uses 24H format but the time picker uses 12H format, which is not consistent.

VERIFIED FIXED

Status

Firefox OS
Gaia::Clock
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: zhang.yonglin, Assigned: iliu@mozilla.com, ianliu.moz@gmail.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

1、set an alarm in 12 hours.
2、the alarm is start on time.


Actual results:

the format of the time is in 24 hours, not in the 12 hours


Expected results:

the format of the time is in 12 hours.
Thanks for firing this but I have difficulties parsing the description. Do you mean:

  1. Supposing it's 11:00am now.
  2. Wanting to set an alarm at 12:00am.
  3. It shows it's going to fire after 12 HOURS 59 MINUTES instead of 59 MINUTES.

If yes, then the behaviour is expected, because 12:00pm usually refer to the *noon* and 12:00am refer to the *midnight*. Please see Bug 796451.
Flags: needinfo?(zhang.yonglin)
(Reporter)

Comment 2

6 years ago
(In reply to Gene Lian [:gene] from comment #1)
> Thanks for firing this but I have difficulties parsing the description. Do
> you mean:
> 
>   1. Supposing it's 11:00am now.
>   2. Wanting to set an alarm at 12:00am.
>   3. It shows it's going to fire after 12 HOURS 59 MINUTES instead of 59
> MINUTES.
> 
> If yes, then the behaviour is expected, because 12:00pm usually refer to the
> *noon* and 12:00am refer to the *midnight*. Please see Bug 796451.

so sorry, you misunderstand what i mean, i mean that the time format is inconsistent, when i set the alarm ,the time is 12-hour format, but when the alarm is on , it's in 24-hour format.
Flags: needinfo?(zhang.yonglin)
Thanks Yonglin! It seems just a UX issue. Sorry for my misunderstanding!

Ivan, is that a UI bug or a UX bug?
Summary: alarm → [Clock] The alarm attention screen uses 24H format but the time picker uses 12H format, which is not consistent.

Comment 4

6 years ago
I think this a bug and is also easy to fix
ping Ian
Assignee: nobody → iliu
Status: UNCONFIRMED → NEW
Ever confirmed: true
I see the console warn as following:
E/GeckoConsole(  585): Content JS WARN at app://clock.gaiamobile.org/shared/js/l10n.js:52 in consoleWarn: [l10n] #dateTimeFormat_%X is undefined.
We need to listen 'localized' event to prevent the warn.
Since the pr(https://github.com/mozilla-b2g/gaia/pull/7191) is merge, we can close the issue now.
Fixed Bug 823431 and this issue.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 7

6 years ago
verified on unagi
build info
12/27
gaia master: a698a8b4018d5e98008ae4ca91bf0ad49c5591ad
b2g-18: 2008afe879e6
Status: RESOLVED → VERIFIED

Comment 8

6 years ago
This issue repros in B2G: Gaia, OS version 1.0.0, Build ID: 20121217070202
Test Case: 1789

Will verify in new build for second test pass

Comment 9

6 years ago
This issue is fixed  in Ungia, build 20130104070203 v.1.0
You need to log in before you can comment on or make changes to this bug.