Failure in testFallbackUpdate/test4.js | Disconnect Error: Application unexpectedly closed

RESOLVED WORKSFORME

Status

Mozilla QA
Mozmill Tests
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: AlexLakatos, Unassigned)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(firefox18 affected)

Details

(Whiteboard: [mozmill-test-failure], URL)

(Reporter)

Description

5 years ago
TEST: /testFallbackUpdate/test4.js::setupModule
ERROR: Disconnect Error: Application unexpectedly closed
WHEN: 2012-12-06
FIRST: 2012-12-06
FREQ: 1
(Reporter)

Updated

5 years ago
status-firefox18: --- → affected
As discussed in the last meeting plesae do not only file the failure but also investigate the problem by analyzing the console log of the Jenkins job.
(Reporter)

Comment 2

5 years ago
Here is the console loG:
http://10.250.73.243:8080/job/ondemand_update/5395/console
Seems the bridge timed out, and that caused that disconnect. There seems there were cleaning up errors after that, some of the files being in use.
Here is the relevant portion of the console log:

Timeout: bridge.execFunction("adbf6f30-3fde-11e2-b39e-005056a26f2a", bridge.registry["{08ac190b-3480-4dcc-a724-47f3040c32ba}"]["runTestFile"], ["c:\\docume~1\\mozilla\\locals~1\\temp\\tmp59jdy4.mozmill-tests\\tests\\update\\testFallbackUpdate\\test4.js"])

TEST-UNEXPECTED-FAIL | Disconnect Error: Application unexpectedly closed
Error Cleaning up: [Error 32] The process cannot access the file because it is being used by another process: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner\\addons.sqlite'
Error Cleaning up: [Error 32] The process cannot access the file because it is being used by another process: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner\\Cache\\_CACHE_001_'
Error Cleaning up: [Error 32] The process cannot access the file because it is being used by another process: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner\\Cache\\_CACHE_002_'
Error Cleaning up: [Error 32] The process cannot access the file because it is being used by another process: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner\\Cache\\_CACHE_003_'
Error Cleaning up: [Error 32] The process cannot access the file because it is being used by another process: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner\\Cache\\_CACHE_MAP_'
Error Cleaning up: [Error 145] The directory is not empty: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner\\Cache'
Error Cleaning up: [Error 32] The process cannot access the file because it is being used by another process: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner\\cert8.db'
Error Cleaning up: [Error 32] The process cannot access the file because it is being used by another process: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner\\content-prefs.sqlite'
Error Cleaning up: [Error 32] The process cannot access the file because it is being used by another process: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner\\cookies.sqlite'
Error Cleaning up: [Error 32] The process cannot access the file because it is being used by another process: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner\\cookies.sqlite-shm'
Error Cleaning up: [Error 32] The process cannot access the file because it is being used by another process: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner\\cookies.sqlite-wal'
Error Cleaning up: [Error 32] The process cannot access the file because it is being used by another process: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner\\downloads.sqlite'
Error Cleaning up: [Error 145] The directory is not empty: 'c:\\docume~1\\mozilla\\locals~1\\temp\\tmplgyede.mozrunner'
INFO Passed: 7
INFO Failed: 1
INFO Skipped: 0
Report document created at 'http://mozauto.iriscouch.com/mozmill-ondemand/352218d7e3125c857fc1d37167c04cfc'
*** Restoring backup of binary (c:\docume~1\mozilla\locals~1\temp\tmpurgywz.binary_backup => c:\docume~1\mozilla\locals~1\temp\tmpwsslxw.binary\)
Setting update channel to 'beta'...
Timeout: bridge.set("91a93aa1-3fdf-11e2-a09f-005056a26f2a", Components.utils.import('resource://mozmill/modules/mozmill.js'))

Execution of test-run aborted: 'MozMillRestart' object has no attribute 'current_test'
'updates'
*** Uninstalling c:\docume~1\mozilla\locals~1\temp\tmpwsslxw.binary\
*** Removing repository 'c:\docume~1\mozilla\locals~1\temp\tmp59jdy4.mozmill-tests'
Traceback (most recent call last):
  File "mozmill-automation/testrun_update.py", line 51, in <module>
    main()
  File "mozmill-automation/testrun_update.py", line 46, in main
    UpdateTestRun().run()
  File "c:\jenkins\workspace\ondemand_update\mozmill-automation\libs\testrun.py", line 942, in run
    TestRun.run(self)
  File "c:\jenkins\workspace\ondemand_update\mozmill-automation\libs\testrun.py", line 439, in run
    raise self.last_exception
KeyError: 'updates'
Process leaked file descriptors. See http://wiki.jenkins-ci.org/display/JENKINS/Spawning+processes+from+build for more information
(In reply to Alex Lakatos[:AlexLakatos] from comment #2)
> Seems the bridge timed out, and that caused that disconnect. There seems
> there were cleaning up errors after that, some of the files being in use.

That's the final reaction, right. But it's not the cause. Please check the log again or especially what you have posted here. There you can see what's failing.

Comment 4

4 years ago
I have checked the last 5 months and haven't seen this failure.
(We've had some disconnects, but in other parts of the update test)

Closing as WFM.
Especially with all recent changes, I don't think this is a valid anymore.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.