If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Browser] missing thumbnails when a place has no screenshot

VERIFIED FIXED

Status

Firefox OS
Gaia::Browser
P3
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: ttaubert, Assigned: ttaubert)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
When a place doesn't have a .screenshot property I get this:

E/GeckoConsole( 7560): [JavaScript Error: "NS_ERROR_INVALID_POINTER: Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIDOMMozURLProperty.createObjectURL]" {file: "app://browser.gaiamobile.org/js/browser.js" line: 1341}]

We should be able to display top sites without a thumbnail/screenshot. The fix is easy.
(Assignee)

Comment 1

5 years ago
Created attachment 689632 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6881/files

Pointer to Github pull-request
(Assignee)

Updated

5 years ago
Attachment #689632 - Flags: review?(ben)
blocking-basecamp: ? → +
Priority: -- → P3
What happens? Default thumbnail shown? White space? Unless the whole page can't be displayed, not going to block on this. Please re-nom if it breaks the whole page.
blocking-basecamp: + → -
Please go through approval process to land this.
(Assignee)

Comment 4

5 years ago
(In reply to Dietrich Ayala (:dietrich) from comment #2)
> What happens? Default thumbnail shown? White space? Unless the whole page
> can't be displayed, not going to block on this. Please re-nom if it breaks
> the whole page.

The whole top-site div is not shown because the .forEach() call aborts with an error. Subsequent top-sites should not be shown as well. Not sure what counts as "breaking the whole page" but it just stays white and empty so I think this doesn't block.
I guess a clearer criteria would be: Does just that top-site not show, or do no top-sites show?

Sounds like the latter, so blocking+.
blocking-basecamp: - → +
Hm, another clarifying question: How often will a top-site not have a thumbnail, and why?
(Assignee)

Comment 7

5 years ago
(In reply to Dietrich Ayala (:dietrich) from comment #6)
> Hm, another clarifying question: How often will a top-site not have a
> thumbnail, and why?

Good question. The site that was failing for me was some kind of WAP portal. Not sure how I got into that situation and if I can reproduce it. The fix seemed so easy to me that I didn't really try to dig into it much further (although I understand this would help categorizing this better).
I'd be happy with a fix that handled thumbnail-less top-sites by putting a placeholder image.
Attachment #689632 - Flags: review?(ben) → review+
Thanks for the patch, sorry for the slow review.

https://github.com/mozilla-b2g/gaia/commit/4053179d9461671c20b2ed98f5bd2659cb74e9a9
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 10

5 years ago
Bug in browser, thumbnail-less top-sites on restarting browser, did not render the site. Patch updated.
Tested on a Unagi Device. 

Reviewd and VERIFIED on:

Build ID : 20130102070202 
Device : Unagi

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.