HealthReportService does not run, fails at startup

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
6 months ago

People

(Reporter: ttaubert, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Reporter)

Description

6 years ago
At B2G startup the following error appears in the console:

E/GeckoConsole( 7889): [JavaScript Error: "NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIXPCComponents_Utils.import]" {file: "jar:file:///system/b2g/omni.ja!/components/HealthReportService.js" line: 10}]

This is caused by:

Cu.import("resource://services-common/preferences.js");

preferences.js is nowhere to be found in the B2G build. Is the HRS supposed to run in B2G? Should this block?

Comment 1

6 years ago
Shouldn't be running right now, policy decision with product later today.
blocking-basecamp: ? → -

Comment 2

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.