redirecton after column change in buglist lost the buglist on InternetExplorer

RESOLVED DUPLICATE of bug 639556

Status

()

Bugzilla
Query/Bug List
RESOLVED DUPLICATE of bug 639556
6 years ago
6 years ago

People

(Reporter: Romain Chauveau, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322; InfoPath.1)

Steps to reproduce:

On IE I make a search request (the search is not important). 
On the buglist, I click on the link "change columns".
I add and/or remove a column and I press "Change Columns".
I wait the automatic-redirection.


Actual results:

The buglist contains more bugs than the first buglist (before change columns).


Expected results:

The buglist must be the same after a column-change. 

I fix this bug with simply quoting the redirection parameter :
 -refresh => "0; URL=\"$vars->{'redirect_url'}\"")

Comment 1

6 years ago
I suppose your Bugzilla uses mod_perl and the URL is truncated after editing columns? The reason why you see more bugs after editing columns seems to confirm this assumption.
Assignee: general → query-and-buglist
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Component: Bugzilla-General → Query/Bug List
Resolution: --- → DUPLICATE
Duplicate of bug: 639556
You need to log in before you can comment on or make changes to this bug.