If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Dialer] Additional calls are received on the device while Call Waiting mode is disabled.

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Dialer
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: CSchmoeckel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Summary: Disabling Call Waiting mode on the device does not prevent additional calls from being received when the user is on an active call. The device receives additional calls as if Call Waiting mode is active no matter what the setting is set to. 
Fails test case: 4375
Daily Build: 20121207062543

Steps to Reproduce: 
1. Device 1 - Open Settings Menu->Call
2. Device 1 - Disable Call Waiting
3. Device 2 - Call Device 1
4. Device 1 - Accept Call from Device 2
5. Device 3 - Call Device 1

Result: The call from Device 3 goes through to Device 1, giving that user the normal accept call or ignore options. 

Expected Result: The call from Device 3 does not go through and that user receives a busy signal.

Updated

5 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
It's been a while since this issue was reported. I failed in reproducing this with
gecko: git, gecko-18 branch, 8ab9f170185b31cc7b4d042eef59088e5901645d (Jan. 15)
gaia: master branch, 8ab9f170185b31cc7b4d042eef59088e5901645d (Jan. 15)

I'll mark it as WFM. Please reopen it if you have different opinions.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 2

5 years ago
Unable to reproduce this bug on build ID 20130211070202 Dec 5th Kernel.  Verified this no longer repros.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.