Camera crashes when a picture is taken

VERIFIED DUPLICATE of bug 819275

Status

Firefox OS
Gaia::Camera
P1
normal
VERIFIED DUPLICATE of bug 819275
5 years ago
5 years ago

People

(Reporter: CKreinbring, Assigned: daleharvey)

Tracking

({crash, regression, smoketest})

unspecified
B2G C2 (20nov-10dec)
ARM
Gonk (Firefox OS)
crash, regression, smoketest

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 689847 [details]
log.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Unagi version:  20121207062543
Eclipse log file is attached.

1. Launch the camera.
2. Tap the camera icon in the middle to take a picture.
3. Observe the app's reaction.




Actual results:

The device returns to the home screen with a message noting that the camera just crashed.


Expected results:

A picture is taken and the app does not have any errors.

Note: A coworker still had version 20121206071128 and was able to take pictures with no errors.
comment 0 implies this isn't reproducible on a recent build. Is that correct?
Keywords: crash
(Reporter)

Comment 2

5 years ago
It does not reproduce on yesterday's build.  Also, the coworker just upgraded his device to today's build and tried to take a picture.  The camera app promptly crashed.

Comment 3

5 years ago
+devs to take a look.
blocking-basecamp: --- → ?
Component: General → Gaia::Camera
Keywords: smoketest
QA Contact: jhammink
I see this on today's build too.

Dale, can this be traced to a recent merge and back it out to get smoketest passing again?
Assignee: nobody → dale
blocking-basecamp: ? → +
Keywords: regression
Priority: -- → P1
Target Milestone: --- → B2G C2 (20nov-10dec)

Comment 5

5 years ago
I found this is the regresstion from bug 815069 and it will be solved by bug 819275.
Which is already  marked as checkin-needed.
Depends on: 819275
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 819275
(Assignee)

Updated

5 years ago
Duplicate of this bug: 819864

Updated

5 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM

Comment 8

5 years ago
Verified as a Duplicate of 819275
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.