[WebAPI] WebMobileConnection data/voice state incorrect when emulator data state is 'searching'

RESOLVED DUPLICATE of bug 866619

Status

()

RESOLVED DUPLICATE of bug 866619
6 years ago
5 years ago

People

(Reporter: rwood, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
I notice that the following is the current behaviour concerning the WebMobileConnection.data.state attribute and the emulator.

I am using the 'gsm data <state>' emulator command to change the data.state, and am using the WebAPI mobileConnection.data.state attribute to get the corresponding value.

Emulator data state ==> corresponding mobileConnection.data.state value:

searching ==> registered

Note from Philipp: "Should be 'searching'. I *think* the phone gets this right, but I'm not sure. So it could just be an emulator bug. Can you please file a bug? Thanks!"

Note: The same behaviour happens with WebMobileConnection.voice.state.

Attached is a marionette WebAPI test script that can be used to reproduce this specific issue on the emulator.
(Reporter)

Comment 1

6 years ago
Created attachment 689883 [details]
Marionette webAPI test for the emulator

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 866619
You need to log in before you can comment on or make changes to this bug.