If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

(Intermittent?) When syncing multiple google calendars sometimes duplicate calendars are visible.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Calendar
P2
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: lightsofapollo, Unassigned)

Tracking

unspecified
B2G C3 (12dec-1jan)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [LOE:S])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Seems like when we sync multiple calendars sometimes I see a duplicate of the same calendar (same name, account and color) but when I edit it on the server (change name or color) it will only update one. It appears that one calendar gets orphaned.
(Reporter)

Updated

5 years ago
Keywords: qawanted
BB+, P2 - once the calendar is not accurate, users may have doubts in trusting the phone's calendar.
blocking-basecamp: ? → +
Priority: -- → P2
This isn't part of bug 810153?

Comment 3

5 years ago
Assigning to Joe.

Jason - can you help find STR with a test GMail account?
Assignee: nobody → jlal
Target Milestone: --- → B2G C3 (12dec-1jan)
(Reporter)

Comment 4

5 years ago
Re #2: No, this is a case where adding a Google account with multiple calendars would occasionally add the calendar twice. The duplicate calendar would not function correctly.
(Reporter)

Updated

5 years ago
Whiteboard: [LOE:S]

Comment 5

5 years ago
Created attachment 693270 [details]
screenshot

I can reproduce this on the 12-17 unagi daily build.  build 20121217070202

STR was to log into my gmail account, and sync my calendars.  I did manually push sync twice, while the first sync was in action.
(Reporter)

Comment 6

5 years ago
Unlikely I am going to have this this week to close this out one out.

This should be fairly easy fix but needs some investigation.
Assignee: jlal → nobody
Can't reproduce with tchung's steps to reproduce with two different google accounts.

Comment 8

5 years ago
:lightsofapollo, it's been a while since this bug has been touched.  do you still need more time here?
Since I got pinged by Dietrich on this, I shall respond on this one:

I've only managed to reproduce this one myself once after a lot of digging, but have yet to get it to consistently repro. If Tony is able to consistently repro, then we should work with him to narrow this down.

But if the probability of reproducing this is too low I'm inclined not to block.
blocking-basecamp: + → ?
tracking-b2g18: --- → ?
Tried really hard, but can't reproduce easily.

If we get a reproduction again, feel free to file a new bug with the details if a consistent repro is found. But digging into this overtime, I've yet to find it consistently reproduce. It's reproduced a week and half ago in one rare instance, but I've been unable to repro it since.
Status: NEW → RESOLVED
blocking-basecamp: ? → ---
Last Resolved: 5 years ago
tracking-b2g18: ? → ---
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.