can't remove a bookmark for a site that gets its URL normalized or redirected

RESOLVED DUPLICATE of bug 804318

Status

Firefox OS
Gaia::Browser
RESOLVED DUPLICATE of bug 804318
5 years ago
5 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
One of the current bookmarks in the default set of bookmarks is to a site that has its URL normalized; the default bookmark is to "http://vds.vivo.br.com", but when the page is loaded (to an error page), the URL gets normalized to having a trailing slash "http://vds.vivo.br.com/".  This means that when the page is loaded, the bookmark star is gray rather than yellow, and the bookmark can't be removed (since that seems to be the only way to remove a bookmark).

The same problem exists for redirects.  If a user bookmarks a page, and that page is later turned into a redirect to another page, the user no longer has the ability to remove the bookmark.

Steps to reproduce (set 1):
 1. start the browser by clicking the Firefox icon at the bottom of the phone's display
 2. click in the URL bar
 3. click on the bookmarks tab
 4. click on the "Músicas Vivo" bookmark
 5. look at the star in the lower right
 6. click on the star

Expected results:
 5. yellow star
 6. UI offers "Unbookmark" option

Actual results (maybe, although an alternative UI for removing bookmarks would probably be superior):
 5. gray star
 6. UI offers "Bookmark" option

Alternatively, one can reproduce by making a Web page on a server you control, bookmarking it, changing that Web page into a redirect, and then going to the bookmark.  (I recommend using a temporary redirect so that the bookmark is easily removable after the redirect is removed from the server.)


Having the default bookmark be in normalized form (see also bug 803328) would remedy this a good bit, though the underlying bug is still likely to be problematic in the long run.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 804318
You need to log in before you can comment on or make changes to this bug.