URL bar should strip /r and /n from multiline pastes to enable pasting of wrapped URLs

VERIFIED DUPLICATE of bug 23485

Status

()

Core
XUL
--
enhancement
VERIFIED DUPLICATE of bug 23485
17 years ago
17 years ago

People

(Reporter: Andrew Thompson, Assigned: Peter Trudelle)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Steps:

Open an email with a long URL in it that's been wrapped onto several lines.

Select all of the lines of the URL and paste it into Mozilla's address bar

What happens:

The first line is pasted, the others are lost

What should happen:

/r and /n characters should be removed from the URL and all lines should be
pasted, so that the users get to goto where they want to go when they press return. 

What will this break:

Nothing I can think of. /r and /n are illegal (and impossible to use unencoded)
in URLs in any case so stripping them shouldn't cause any problems.

Presumably there's already a maximum limit on how many characters the URL bar
will accept? 
Obviously, we wouldn't want implementing this to allow the user to paste a 200
page document into the URL bar and crash the browser, but that shouldn't be
possible anyway, right?

Comment 1

17 years ago
I'd like to try fixing this if nobody else has started the work.

Comment 2

17 years ago
There is a duplicate of this bug/rfe out there somewhere, and if I recall 
correctly, it does discuss some pros and cons. Have a look for that first
(hint: I'm sure that akkana either owns this, or is on the CC: list)

Comment 3

17 years ago
You're right, John.  This is a dup of bug 23485.  Thanks.


*** This bug has been marked as a duplicate of 23485 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.