Closed Bug 819630 Opened 9 years ago Closed 9 years ago

Firefox 20 crash in nsCacheService::Unlock

Categories

(Core :: Networking: Cache, defect)

20 Branch
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox19 --- unaffected
firefox20 --- affected

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, regression, topcrash)

Crash Data

It's #7 top crasher in today's build and first showed up in 20.0a1/20121206 along with many other crashes. The regression range for the spike is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1942b4d64dc8&tochange=3c81e1c0d252
I suspect bug 801466.

Stack traces are various:
Frame 	Module 	Signature 	Source
0 	xul.dll 	nsCacheService::Unlock 	netwerk/cache/nsCacheService.cpp:2634
1 	xul.dll 	nsCacheEntryDescriptor::nsOutputStreamWrapper::LazyInit 	netwerk/cache/nsCacheEntryDescriptor.cpp:831
2 	xul.dll 	nsCacheEntryDescriptor::nsOutputStreamWrapper::Write 	netwerk/cache/nsCacheEntryDescriptor.cpp:900
3 	xul.dll 	nsInputStreamTeeWriteEvent::Run 	xpcom/io/nsInputStreamTee.cpp:105
4 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:627
...

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsCacheService::Unlock 	netwerk/cache/nsCacheService.cpp:2634
1 	xul.dll 	nsCacheEntryDescriptor::RequestDataSizeChange 	netwerk/cache/nsCacheEntryDescriptor.cpp:268
2 	xul.dll 	nsCacheEntryDescriptor::nsOutputStreamWrapper::Write 	netwerk/cache/nsCacheEntryDescriptor.cpp:903
3 	xul.dll 	nsInputStreamTeeWriteEvent::Run 	xpcom/io/nsInputStreamTee.cpp:105
4 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:627
...

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsCacheService::Unlock 	netwerk/cache/nsCacheService.cpp:2634
1 	xul.dll 	nsDiskCacheStreamIO::Write 	netwerk/cache/nsDiskCacheStreams.cpp:610
2 	xul.dll 	nsDiskCacheOutputStream::Write 	netwerk/cache/nsDiskCacheStreams.cpp:283
3 	xul.dll 	nsCacheEntryDescriptor::nsOutputStreamWrapper::Write 	netwerk/cache/nsCacheEntryDescriptor.cpp:906
4 	xul.dll 	nsInputStreamTeeWriteEvent::Run 	xpcom/io/nsInputStreamTee.cpp:105
5 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:627
...

Frame 	Module 	Signature 	Source
0 	XUL 	nsCacheService::Unlock 	nsCacheService.cpp:2634
1 	XUL 	nsDiskCacheOutputStream::Close 	nsCacheService.h:374
2 	XUL 	nsCacheEntryDescriptor::nsOutputStreamWrapper::~nsOutputStreamWrapper 	nsCacheEntryDescriptor.cpp:883
3 	XUL 	nsCacheEntryDescriptor::nsOutputStreamWrapper::Release 	nsCacheEntryDescriptor.cpp:821
4 	XUL 	nsProxyReleaseEvent::Run 	nsProxyRelease.cpp:19
5 	XUL 	nsThread::ProcessNextEvent 	nsThread.cpp:627 
...

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsCacheService::Unlock 	netwerk/cache/nsCacheService.cpp:2634
1 	xul.dll 	nsCacheEntryDescriptor::nsInputStreamWrapper::LazyInit 	netwerk/cache/nsCacheEntryDescriptor.cpp:618
2 	xul.dll 	nsCacheEntryDescriptor::nsInputStreamWrapper::Close 	netwerk/cache/nsCacheEntryDescriptor.cpp:642
3 	xul.dll 	mozilla::net::nsHttpChannel::CloseCacheEntry 	netwerk/protocol/http/nsHttpChannel.cpp:3499
4 	xul.dll 	mozilla::net::nsHttpChannel::OnStopRequest 	netwerk/protocol/http/nsHttpChannel.cpp:5049
5 	xul.dll 	nsInputStreamPump::OnStateStop 	netwerk/base/src/nsInputStreamPump.cpp:552
6 	xul.dll 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:374
7 	xul.dll 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:82
8 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:627
...

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsCacheService::Unlock 	netwerk/cache/nsCacheService.cpp:2634
1 	xul.dll 	nsCacheEntryDescriptor::SetExpirationTime 	netwerk/cache/nsCacheEntryDescriptor.cpp:197
2 	xul.dll 	mozilla::net::nsHttpChannel::UpdateExpirationTime 	netwerk/protocol/http/nsHttpChannel.cpp:2741
3 	xul.dll 	mozilla::net::nsHttpChannel::InitCacheEntry 	netwerk/protocol/http/nsHttpChannel.cpp:3587
4 	xul.dll 	mozilla::net::nsHttpChannel::ContinueProcessNormal 	netwerk/protocol/http/nsHttpChannel.cpp:1436
5 	xul.dll 	mozilla::net::nsHttpChannel::ProcessNormal 	netwerk/protocol/http/nsHttpChannel.cpp:1403
6 	xul.dll 	mozilla::net::nsHttpChannel::ProcessResponse 	netwerk/protocol/http/nsHttpChannel.cpp:1238
7 	xul.dll 	mozilla::net::nsHttpChannel::OnStartRequest 	netwerk/protocol/http/nsHttpChannel.cpp:4846
8 	xul.dll 	nsInputStreamPump::OnStateStart 	netwerk/base/src/nsInputStreamPump.cpp:417
9 	xul.dll 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:368
10 	xul.dll 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:82
11 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:627
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsCacheService%3A%3AUnlock%28%29
Blocks: 801466
Crashes have stopped since 20.0a1/20121208, maybe fixed by the patch of bug 818962.
No longer blocks: 801466
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.