crash in nsComponentManagerImpl::GetServiceByContractID

RESOLVED WORKSFORME

Status

()

Core
XPCOM
--
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression, topcrash})

20 Branch
All
Windows 7
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(firefox19 unaffected, firefox20 affected)

Details

(crash signature)

(Reporter)

Description

5 years ago
It started spiking in 20.0a1/20121206. It's currently #10 top crasher in today's build. The regression range for the spike is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1942b4d64dc8&tochange=3c81e1c0d252
I suspect bug 801466.

Stack traces are various:
Frame 	Module 	Signature 	Source
0 	xul.dll 	nsComponentManagerImpl::GetServiceByContractID 	xpcom/components/nsComponentManager.cpp:1360
1 	xul.dll 	mozilla::net::HttpCacheQuery::Run 	netwerk/protocol/http/nsHttpChannel.cpp:2795
2 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:627
3 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:265
...

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsComponentManagerImpl::GetServiceByContractID 	xpcom/components/nsComponentManager.cpp:1360
1 	xul.dll 	nsCOMPtr_base::assign_from_gs_contractid 	obj-firefox/xpcom/build/nsCOMPtr.cpp:92
2 	xul.dll 	imgRequest::OnStartRequest 	image/src/imgRequest.cpp:602
3 	xul.dll 	ProxyListener::OnStartRequest 	image/src/imgLoader.cpp:2053
4 	xul.dll 	mozilla::net::nsHttpChannel::CallOnStartRequest 	netwerk/protocol/http/nsHttpChannel.cpp:975
5 	xul.dll 	nsDeviceContext::GetMetricsFor 	gfx/src/nsDeviceContext.cpp:256
...

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsComponentManagerImpl::GetServiceByContractID 	xpcom/components/nsComponentManager.cpp:1360
1 	xul.dll 	nsCOMPtr_base::assign_from_gs_contractid 	obj-firefox/xpcom/build/nsCOMPtr.cpp:92
2 	xul.dll 	nsScriptLoader::ConvertToUTF16 	content/base/src/nsScriptLoader.cpp:1100
3 	xul.dll 	nsScriptLoader::PrepareLoadedRequest 	content/base/src/nsScriptLoader.cpp:1205
4 	xul.dll 	nsScriptLoader::OnStreamComplete 	content/base/src/nsScriptLoader.cpp:1116
5 	xul.dll 	nsStreamLoader::OnStopRequest 	netwerk/base/src/nsStreamLoader.cpp:101
6 	xul.dll 	nsMultipartProxyListener::OnStopRequest 	netwerk/streamconv/converters/nsHTTPCompressConv.cpp:94
7 	xul.dll 	nsStreamListenerTee::OnStopRequest 	netwerk/base/src/nsStreamListenerTee.cpp:49
8 	xul.dll 	mozilla::net::nsHttpChannel::OnStopRequest 	netwerk/protocol/http/nsHttpChannel.cpp:5027
9 	xul.dll 	nsInputStreamPump::OnStateStop 	netwerk/base/src/nsInputStreamPump.cpp:552
10 	xul.dll 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:374
11 	xul.dll 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:82
12 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:627
...

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsComponentManagerImpl::GetServiceByContractID 	xpcom/components/nsComponentManager.cpp:1360
1 	xul.dll 	nsCOMPtr_base::assign_from_gs_contractid 	obj-firefox/xpcom/build/nsCOMPtr.cpp:92
2 	xul.dll 	nsMenuPopupFrame::GetConstraintRect 	layout/xul/base/src/nsMenuPopupFrame.cpp:1317
3 	xul.dll 	nsMenuPopupFrame::SetPopupPosition 	layout/xul/base/src/nsMenuPopupFrame.cpp:1222
4 	xul.dll 	nsMenuPopupFrame::LayoutPopup 	layout/xul/base/src/nsMenuPopupFrame.cpp:445
5 	xul.dll 	nsPopupSetFrame::DoLayout 	layout/xul/base/src/nsPopupSetFrame.cpp:122
6 	xul.dll 	nsSprocketLayout::Layout 	layout/xul/base/src/nsSprocketLayout.cpp:481
7 	xul.dll 	nsBoxFrame::DoLayout 	layout/xul/base/src/nsBoxFrame.cpp:900
8 	xul.dll 	nsStackLayout::Layout 	layout/xul/base/src/nsStackLayout.cpp:340
9 	xul.dll 	nsBoxFrame::DoLayout 	layout/xul/base/src/nsBoxFrame.cpp:900
10 	xul.dll 	nsIFrame::Layout 	layout/xul/base/src/nsBox.cpp:510
11 	xul.dll 	nsBoxFrame::Reflow 	layout/xul/base/src/nsBoxFrame.cpp:695
...

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsComponentManagerImpl::GetServiceByContractID 	xpcom/components/nsComponentManager.cpp:1360
1 	xul.dll 	nsIOService::GetProtocolHandler 	netwerk/base/src/nsIOService.cpp:417
2 	xul.dll 	nsIOService::GetProtocolFlags 	netwerk/base/src/nsIOService.cpp:494
3 	xul.dll 	nsIOService::ProtocolHasFlags 	netwerk/base/src/nsIOService.cpp:981
4 	xul.dll 	nsIOService::URIChainHasFlags 	netwerk/base/src/nsIOService.cpp:995
5 	xul.dll 	NS_URIChainHasFlags 	obj-firefox/dist/include/nsNetUtil.h:1665
6 	xul.dll 	nsCookiePermission::CanAccess 	extensions/cookie/nsCookiePermission.cpp:160
...

and so on.

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsComponentManagerImpl%3A%3AGetServiceByContractID%28char+const*%2C+nsID+const%26%2C+void**%29
(Reporter)

Updated

5 years ago
Crash Signature: [@ nsComponentManagerImpl::GetServiceByContractID(char const*, nsID const&, void**)] → [@ nsComponentManagerImpl::GetServiceByContractID(char const*, nsID const&, void**)] [@ PR_EnterMonitor | nsComponentManagerImpl::GetServiceByContractID(char const*, nsID const&, void**)]
(Reporter)

Comment 1

5 years ago
Crashes have stopped since 20.0a1/20121208, maybe fixed by the patch of bug 818962.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
tracking-firefox20: ? → ---
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.