configure --disable-webm results in link failure because of missing libogg/libvorbis

RESOLVED DUPLICATE of bug 929398

Status

()

RESOLVED DUPLICATE of bug 929398
6 years ago
5 years ago

People

(Reporter: tijl, Unassigned)

Tracking

17 Branch
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 690104 [details]
proposed patch

When I run configure --disable-webm and then build firefox it ends with a link failure (libtheora requires libogg and libvorbis).

It seems that the --enable-ogg option (default) does not set MOZ_VORBIS in configure.in. The attached patch should fix it.

Comment 1

5 years ago
This one seems to be fixed by bug 929398. Recently, --disable-webm is broken by MOZ_WEBM_ENCODER (bug 964484).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 929398
You need to log in before you can comment on or make changes to this bug.